summaryrefslogtreecommitdiff
path: root/dev-python/python-socks/python-socks-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 23:51:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 23:51:35 +0100
commit3e488f4a5f53b007af8cc3180f9ac0abfe5a0be8 (patch)
tree3a5fcb18d05b450eddb486845092460150afe2ad /dev-python/python-socks/python-socks-2.0.3.ebuild
parentd83532aee7e94505bf23da29e6224ca164aac759 (diff)
gentoo auto-resync : 16:04:2023 - 23:51:35
Diffstat (limited to 'dev-python/python-socks/python-socks-2.0.3.ebuild')
-rw-r--r--dev-python/python-socks/python-socks-2.0.3.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/python-socks/python-socks-2.0.3.ebuild b/dev-python/python-socks/python-socks-2.0.3.ebuild
deleted file mode 100644
index 53d769be9c0a..000000000000
--- a/dev-python/python-socks/python-socks-2.0.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
-HOMEPAGE="
- https://pypi.org/project/python-socks/
- https://github.com/romis2012/python-socks/"
-SRC_URI="
- https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-# curio is not packaged
-# asyncio is the only backend we have, so dep on its deps unconditionally
-# TODO: revisit
-RDEPEND="dev-python/async-timeout[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- ' 'python*')
- dev-python/async-timeout[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- # can be removed on next version bump
- epytest --asyncio-mode=strict
-}