summaryrefslogtreecommitdiff
path: root/dev-python/python-social-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-social-auth
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-social-auth')
-rw-r--r--dev-python/python-social-auth/Manifest5
-rw-r--r--dev-python/python-social-auth/metadata.xml11
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.1.26.ebuild56
-rw-r--r--dev-python/python-social-auth/python-social-auth-0.2.10.ebuild57
4 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/python-social-auth/Manifest b/dev-python/python-social-auth/Manifest
new file mode 100644
index 000000000000..a0395d56b9c4
--- /dev/null
+++ b/dev-python/python-social-auth/Manifest
@@ -0,0 +1,5 @@
+DIST python-social-auth-0.1.26.tar.gz 247579 BLAKE2B 647299350462d707d054df6b64438fd71f2ec28c047a0dda21432a3488d26e1adec86ffe7a1cd09d2a7bc658e661e065df9a06e3058da3c16dfe22b5b85402bb SHA512 c3637f9a269f2c8465b1896840a5ca0f70bb6c45c93f7d9c08c54434037984538ba95442a164841c069cb5b1fd251d0f3f62baa1dc2754a542baceb2f325bd8b
+DIST python-social-auth-0.2.10.tar.gz 297210 BLAKE2B b312211ad11d4d1d1d12dcb607e87064b4bd2cf929c71b513a665839365510e0768151de4b3e56dd9a05fe9d8e4fe7368bc7f234c01f20e3d2898c709102ae29 SHA512 af5247cee0b77f36d1bfdd7457708c2f2053bc779bae8eae0cfe79f0f9236c37882afcbd325863255282eb7559d8f84715b3e983f94d55bd3e7815c5469f150d
+EBUILD python-social-auth-0.1.26.ebuild 1475 BLAKE2B 1774b17aaa99e1ed4e87182df8f38098bb6cd0ff65fe5a3e7475438a58fca5f214fdd8bebdc646741b3c44343d17e1e664aed8b65a5bafb3eab503a3aa2d3b2a SHA512 6418a043c6b63db4fe80d72b8cfeec6612c6dced724d722fbe173bbf8574acf233dab768188887085f79ea8ee0a0bf7ca657c9bede3286092f73170fc1545cc2
+EBUILD python-social-auth-0.2.10.ebuild 1527 BLAKE2B 4edd6648caaf97ecbad96c7df1d89023715a3d2872d2df5b92a8ec9318d3257f1445ef3b60ad821a4bba082b6fdf9a77ffa7544f04976cf35af39d3c1f8fc40a SHA512 c69db0fa4e38f0fcc70221b8bb9a31b8b8a751d084ff8399ab441a2be32c504ba54405eacbeacb58bcdb59f3b231490d2e6bef9ae1c29cf2f059d518d134fd13
+MISC metadata.xml 338 BLAKE2B 3ca07987fa6ffe23b4dcb728f803fdf0a32add0ed9f7605de53a11e365b7e1ed1a83eb1f39780702af3bcc98345e85330233c1d622ad3b61773f57acb4bb27ff SHA512 368ff17c8b2533952749b5d757fdfde6932977a00ca3278ffd5e403b22aa6c51471c413f6311c05ca3001f077735826cec63ac30c4b1926925e91d74bc50060a
diff --git a/dev-python/python-social-auth/metadata.xml b/dev-python/python-social-auth/metadata.xml
new file mode 100644
index 000000000000..2f61c1adb476
--- /dev/null
+++ b/dev-python/python-social-auth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">omab/python-social-auth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild b/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
new file mode 100644
index 000000000000..7c1e44660d9d
--- /dev/null
+++ b/dev-python/python-social-auth/python-social-auth-0.1.26.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
+HOMEPAGE="http://psa.matiasaguirre.net/"
+SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc examples test"
+
+RDEPEND="
+ $(python_gen_cond_dep \
+ 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep \
+ 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
+ >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+# tests require internet
+#"
+# test? (
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/httpretty[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/sure[${PYTHON_USEDEP}]
+# )
+#"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+#python_test() {
+# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
+#}
diff --git a/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild b/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
new file mode 100644
index 000000000000..8c8f3c7a876e
--- /dev/null
+++ b/dev-python/python-social-auth/python-social-auth-0.2.10.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to setup social auth mechanism with support for several frameworks and auth providers"
+HOMEPAGE="http://psa.matiasaguirre.net/"
+SRC_URI="https://github.com/omab/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc examples test"
+
+RDEPEND="
+ $(python_gen_cond_dep \
+ 'dev-python/python-openid[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep \
+ 'dev-python/python3-openid[${PYTHON_USEDEP}]' 'python3*')
+ >=dev-python/oauthlib-0.3.8[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.2.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ >=dev-python/six-1.2.0[${PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+# tests require internet
+#"
+# test? (
+# dev-python/coverage[${PYTHON_USEDEP}]
+# dev-python/httpretty[${PYTHON_USEDEP}]
+# dev-python/mock[${PYTHON_USEDEP}]
+# dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/sure[${PYTHON_USEDEP}]
+# )
+#"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
+
+#python_test() {
+# "${S}"/social/tests/run_tests.sh || die "Tests failed on ${EPYTHON}"
+#}