summaryrefslogtreecommitdiff
path: root/dev-python/python-slugify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
commitcd1445321d1a6609cc7215588a79b2232c8a9bd3 (patch)
treefb9d68dde365101c0774ba4166a38ab3afa0e362 /dev-python/python-slugify
parentb8ec9071f5d20d8518b02d0077428b2c9f88861b (diff)
gentoo auto-resync : 29:01:2023 - 08:54:36
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest2
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 55073e40bdef..b8ebfa8e4c63 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,3 +1,5 @@
DIST python-slugify-7.0.0.gh.tar.gz 13257 BLAKE2B 6d50fd25ac89caed3a970f4cce786d9b61de68386fc183659c0d884877edc934e121ad07316259af08deb61a30ac33f0076a90b2d5a650dfb113e6b6416addfe SHA512 c22743a28ffb273546541eaf59d2a7beb9070a7f81e504acaf73d220c2be83a87d02012b5841076539ba6bae5778dd47309ee7ceef9f8479c993dda6b3e09837
+DIST python-slugify-8.0.0.gh.tar.gz 13322 BLAKE2B 146b04d75aa1aefa0a28824c2c3dd3f323ddfd49dbaafc82a9d9401de8fbdea25793c833e17b4a04cfc646fa371a0a10c40011be870fef573a8f0f8977671d26 SHA512 24d9309873c5bd625a9301b3a7844c7a1f3d2adb5faad9e49563446e33ab08f3d984c6692fb36885fdc363bee8c86252092ea0fc8f1b70152cff3365db37fd82
EBUILD python-slugify-7.0.0.ebuild 599 BLAKE2B 403a61cb2a0cacead0ff389e974920fece69a80b58cdc81eda49a1b769f5bbbb7b13c3478e2a35cb3811985d927ffa35926b6e38eb86ad5eee12e279013f97cc SHA512 2cec94651006b6bcd53e202abd9109f5c83c61bd58e4490619d558ff97b66c8636c5a17155b0e2752cb2a60a346c3ef54b1f5cd0dc61ce9b90233a481f62dcc8
+EBUILD python-slugify-8.0.0.ebuild 601 BLAKE2B c3c7f22e6462af838a305e296324036b3f2da0be811f9f3419b85f81f83b286ad8d7a7276fe1fb5bcb535505aafd47f700fcb9bacb73397b0281f7b5aee74cda SHA512 5c75a390540a9d839d4abae7fc9195fc62594c38873eb5f26cbe73c3ca2c7db1f938996631da98bcb1c7ec1f670b79f4a1b709a295c7fad195bfa5b19eaa6349
MISC metadata.xml 637 BLAKE2B 4869f272370af0065e6d0479d660a8fba6665ad019a3072cb3a2f1b003fa0cd7ae57dc8e19ad8ceda33d97355c1e4d1ebebb96978935d016fa8bcd2b7fd72660 SHA512 bc09a7914759371c03436e5dd0ef50bc1972cfbf2b815e91048d78d277402d8431be59673f4106483b690dfe3b3cde7ca5e39719effc23dc77e1e9b505e14a01
diff --git a/dev-python/python-slugify/python-slugify-8.0.0.ebuild b/dev-python/python-slugify/python-slugify-8.0.0.ebuild
new file mode 100644
index 000000000000..e80db8044cf6
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest