summaryrefslogtreecommitdiff
path: root/dev-python/python-slugify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /dev-python/python-slugify
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest2
-rw-r--r--dev-python/python-slugify/python-slugify-5.0.0.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index 72b198b030ec..2badc066af14 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,5 +1,7 @@
DIST python-slugify-1.2.6.tar.gz 8439 BLAKE2B 74699bf80408e1b6a705525b0ada2612cc6224a2ac1e17ce21230ed684af144c0f72ad99b32674bf19bd716d2cfc3a2f0da6f74facc99acba16e3ebc1873f3f3 SHA512 ad45958d03892d8db75967b150f25509c05ab2a87d5ac4a2ed12fccccfe1f86d7db26c406c6de22ba759b77fe772cc0c00d0e517c71db085618f62094ddadfd2
DIST python-slugify-4.0.1.tar.gz 11509 BLAKE2B b505c62c959dae3823db4441b8811ed98ec8afa0278325cb2715abb63a84b5de1506362699bc39216bbac4100ae265671f940dbbbdaf9164fd251bdaa7af462a SHA512 c1d99a9dc891c4cfa927e4d2bc5701f47b23b7882cce22350283a53c6ded18e1290196c3bb9838883c29c9cb3582e5e684edffd50dfbb4e9da9c2b821ea54bb5
+DIST python-slugify-5.0.0.tar.gz 11730 BLAKE2B 0ec93c230523bcd4ba5f917bc9d2676ae92fc164eccc84198777a59c36ff427fdb7a242bd89f9bc3d24e86b5a1d106f0118cf118349de648f5779c384445abab SHA512 b29c542ec3cb3d05d88be0fb53909b160022fe97dbc89efc0eef5f4e2414031026f570dd6eec1e7bbe2930d801c2fd8d152e49cd2639cddb23392c9b11e7266b
EBUILD python-slugify-1.2.6.ebuild 591 BLAKE2B 55ace80e2b6c0f3b22ef75356bdd0d0d885edfa30fbb2022fb0839fe42ec968cd4331a08d081fb81ca39c10b4a506c052893addda6963ba576e3e99eae6092f9 SHA512 0b6479877191bfb5513a86fe807fcd119970f88528a138c5cb0574008cc59e0f9265df5c873061023b1b8ecd1000b95aa338c3a13dbbe6ecbdcf34dfd2119933
EBUILD python-slugify-4.0.1.ebuild 583 BLAKE2B 8a24e14e645cdcc33b3939f59be05fbfa392e8c45f3f470faa2a4c4399ca744088929151b7879635a42cf33dbd488f7126bf4deb830773100676f1f92372ca7d SHA512 1a7b87916cda00f28d41751f6d306137d9a04ca78e300a0b3846bac7d8e07b50e794f84418240823d1d4dea78a77f9c22719ccfc3ba4a56690f9935d5378f70d
+EBUILD python-slugify-5.0.0.ebuild 552 BLAKE2B fb002d5d30d432489cf4fd4c3531b49109d6afa5875c97b93b1ba5d2151d45b900533aedc51e53735b77805e3e486f8052c51f9213ece8c6047caa023b892936 SHA512 b7afcc6766b69cde0d0f3b617bf135f8b39ea279442c21f47052ddafef290fdcfafac4bde73fe69b6dccbde36105b7e83580e56bd6bae7938395b2feddaaaa31
MISC metadata.xml 636 BLAKE2B 67238b65f26d08870b390e38a5366992fd40770f843201ebc930689a3e0819d2446e4dcb9b7b128873ff05ad964edc58b478a4134a563669c718fc890337b054 SHA512 144bb0c8a9249471ef29f015d18349c0a142426b28fbcedf21f83fc9b66b5634e3f1a2e7aa53544d57a2045ca3cf4eb3b76f07f8296253517c14f9d6f8906d46
diff --git a/dev-python/python-slugify/python-slugify-5.0.0.ebuild b/dev-python/python-slugify/python-slugify-5.0.0.ebuild
new file mode 100644
index 000000000000..ae681ae6129d
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-5.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="https://github.com/un33k/python-slugify https://pypi.org/project/python-slugify/"
+SRC_URI="https://github.com/un33k/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/text-unidecode[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest