summaryrefslogtreecommitdiff
path: root/dev-python/python-slip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /dev-python/python-slip
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'dev-python/python-slip')
-rw-r--r--dev-python/python-slip/Manifest1
-rw-r--r--dev-python/python-slip/python-slip-0.6.5-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-slip/Manifest b/dev-python/python-slip/Manifest
index 9f4372947b17..3b834f35e862 100644
--- a/dev-python/python-slip/Manifest
+++ b/dev-python/python-slip/Manifest
@@ -1,4 +1,5 @@
AUX python-slip-0.6.5-no-selinux.patch 2942 BLAKE2B 87cb1fee6aba70228b78ffc8b8a63b6b3bc0b11aad8f5e38369919e6c5a33780a9f255c2c81cc9220fe02b11b8d6daf24278bdbc495a831af03c92f1f2bd25f1 SHA512 64a742f93a38a2ff15d98e9d22c30a821ecd2044457ac958bf34cd7fd8e333b16a5fd56e80b169cc67c9ab35d13298d0caf418ad7a693372539701bda56f123e
DIST python-slip-0.6.5.tar.bz2 25996 BLAKE2B f2c512274c35a451aa5a97f8c8b16d117edc34901cb2cc51d7d99314eec9c2e90c95019290ef9a35511b62a822471f40eac8c4228c0094bd72c71bd579bbe0c5 SHA512 84dfd4d74602e996797261aa4021fc1579a6aba554d2b3d497c0a7b8618366a9c0a6f12051b00c5653845dda923eedb58afdded37f2a1f31b5b0ce1a0532ccff
+EBUILD python-slip-0.6.5-r1.ebuild 1116 BLAKE2B 07525835731560ce5e9a0a279da61a78542b1405115f229beb8537d66794fc3d03d29782c30fc746a778c9cb7057eeda65cde94c6484c017f46d54cb7b5a8a3e SHA512 064012118af772a241eb53d55bae054fcc927d31b3b004b8359d9dd55e3a38da893728947cdba982b39b5e6b7717c705eb89cdb4f61a8858383787488948269e
EBUILD python-slip-0.6.5.ebuild 1219 BLAKE2B 717994a011b6f496749131fb8cab3af553de7f33b61ad9ba85588b2d093aa16dd090d668a0250d10a55c839ebb5af4c7268e755a59d6cb45c02e37b47454b1a5 SHA512 8a74e30721166034494235462ead53b82788f7975c3cc8cc7d87002f85babd5de31480877a40459d672f92b6066cf1f15a203985649d84d9723f6cd64045d598
MISC metadata.xml 277 BLAKE2B fdd3d0858258cd42bb21a1759e210802c20d42422a6b527e43f7c2488162ecc74b31a8098018999b986f23fefa9ce8752f59bce9dbd1becc6044e5a5b999c2cf SHA512 a7f1ef17d50370f30622f5a9f9a3d69623214ce9e1eb76fb9d59fcd8e016a2dfa18e6141ee130e7e1c6dab517d274ae8d252638a27320e356d4f7267d09587db
diff --git a/dev-python/python-slip/python-slip-0.6.5-r1.ebuild b/dev-python/python-slip/python-slip-0.6.5-r1.ebuild
new file mode 100644
index 000000000000..d1ccb54c86e0
--- /dev/null
+++ b/dev-python/python-slip/python-slip-0.6.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Miscellaneous convenience, extension and workaround code for Python"
+HOMEPAGE="https://github.com/nphilipp/python-slip"
+SRC_URI="https://github.com/nphilipp/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="dbus selinux"
+
+RDEPEND="
+ dbus? (
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sys-auth/polkit
+ )
+"
+
+python_prepare_all() {
+ use selinux || eapply -p1 "${FILESDIR}"/${PN}-0.6.5-no-selinux.patch
+
+ # Disable gtk interface since it's gtk-2.
+ sed \
+ -e 's|sys.version_info.major == 2|False|' \
+ -e "s:@VERSION@:${PV}:" setup.py.in > setup.py || die
+
+ # Enable / disable dbus support by user choice.
+ if ! use dbus; then
+ sed -e '/name="slip.dbus"/ s/\(.*\)/if 0:\n \1/' \
+ -i setup.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}