summaryrefslogtreecommitdiff
path: root/dev-python/python-slip/python-slip-0.6.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/python-slip/python-slip-0.6.5-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/python-slip/python-slip-0.6.5-r1.ebuild')
-rw-r--r--dev-python/python-slip/python-slip-0.6.5-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/python-slip/python-slip-0.6.5-r1.ebuild b/dev-python/python-slip/python-slip-0.6.5-r1.ebuild
deleted file mode 100644
index 36a8e2b4a6ad..000000000000
--- a/dev-python/python-slip/python-slip-0.6.5-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_REQ_USE="xml"
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Miscellaneous convenience, extension and workaround code for Python"
-HOMEPAGE="https://github.com/nphilipp/python-slip"
-SRC_URI="https://github.com/nphilipp/${PN}/releases/download/${P}/${P}.tar.bz2"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE="dbus selinux"
-
-RDEPEND="
- dbus? (
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- sys-auth/polkit
- )
-"
-
-python_prepare_all() {
- use selinux || eapply -p1 "${FILESDIR}"/${PN}-0.6.5-no-selinux.patch
-
- # Disable gtk interface since it's gtk-2.
- sed \
- -e 's|sys.version_info.major == 2|False|' \
- -e "s:@VERSION@:${PV}:" setup.py.in > setup.py || die
-
- # Enable / disable dbus support by user choice.
- if ! use dbus; then
- sed -e '/name="slip.dbus"/ s/\(.*\)/if 0:\n \1/' \
- -i setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}