summaryrefslogtreecommitdiff
path: root/dev-python/python-sense-hat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-sense-hat
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-sense-hat')
-rw-r--r--dev-python/python-sense-hat/Manifest3
-rw-r--r--dev-python/python-sense-hat/metadata.xml12
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild23
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-sense-hat/Manifest b/dev-python/python-sense-hat/Manifest
new file mode 100644
index 000000000000..904c3cbbd67e
--- /dev/null
+++ b/dev-python/python-sense-hat/Manifest
@@ -0,0 +1,3 @@
+DIST python-sense-hat-2.2.0.tar.gz 20841 BLAKE2B 59e6b9111fb90493e6bda00ce4a4c143dcb84d8b6529efadaf2f337adb38a8fb4287cbd9a303070ea4f335f1e03c6f4789e6f8fbe64a7c70db20675bdae7c6a1 SHA512 71914f6f22206cff23992a6908698978741a46bf9b98648388bac4550f39e8de73db6bd389b79585eba6e82160649a8c8da4217d515bbdbcb50d47218415f3ac
+EBUILD python-sense-hat-2.2.0.ebuild 618 BLAKE2B 3cc52722c66c5ed62de0dfe579bcba3091c5aeab55874c2d0fceec99b6842526b7befc44daedf689feb6c2b3df70e9d47a4a522cafad031e2961b06b7885cfee SHA512 b7e214bf47fc6650732acf95a7681f994bc5efc39e87703d7f3bcad0058d9b5c639191c9ba7f8667465e86595b7341c89ce9b62870184114e366afb1f1cb0b8b
+MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
diff --git a/dev-python/python-sense-hat/metadata.xml b/dev-python/python-sense-hat/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/dev-python/python-sense-hat/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild
new file mode 100644
index 000000000000..e941ad6c7acc
--- /dev/null
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raspberry Pi Sense HAT python library"
+HOMEPAGE="https://github.com/RPi-Distro/python-sense-hat"
+SRC_URI="https://github.com/RPi-Distro/python-sense-hat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~arm ~arm64"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/rtimulib[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"