summaryrefslogtreecommitdiff
path: root/dev-python/python-scsi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-scsi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-scsi')
-rw-r--r--dev-python/python-scsi/Manifest4
-rw-r--r--dev-python/python-scsi/metadata.xml11
-rw-r--r--dev-python/python-scsi/python-scsi-0_pre160211.ebuild27
-rw-r--r--dev-python/python-scsi/python-scsi-9999.ebuild20
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/python-scsi/Manifest b/dev-python/python-scsi/Manifest
new file mode 100644
index 000000000000..058ae882e9c6
--- /dev/null
+++ b/dev-python/python-scsi/Manifest
@@ -0,0 +1,4 @@
+DIST python-scsi-0_pre160211.zip 126606 BLAKE2B d5992732b2673ea5136f46e985a63bcb9d0285d67b314005cb3ee4ca447043c31654c8ddf038c01472b2d30ba7f10f4152461ce080fdcc496dad84513f0310c3 SHA512 43218dfe91eba8f79c0cc7b48e5d7ba3026aac3d0c70dc2d8865905ef70bc479c6a32c46104b3284a00b5832d8893daf4285aac84fd43f1a1ba80affeaf5e258
+EBUILD python-scsi-0_pre160211.ebuild 647 BLAKE2B f6be1aaa276bdaa646683552ba2e34164bcddcc9ac6656633a41c106ca2a9e8b31382e48f7b005ae2872156a30fb87b7096e95615dc785769c449e24dfda87ad SHA512 693f23f63935aa6b04d37e90defa93f130e1eead9d420ac0c018751eba80b798076a5948a72e832c236753f20689b4deee4eeb54aeea4d7e12533de963b7bb99
+EBUILD python-scsi-9999.ebuild 447 BLAKE2B b5c9a6944f610c240fd05cde084eb1bc01f6ee3ce4c5ca1510171c90cf9e2a6100af2d61904dfa73df2c0cad04a694db1f91a7e0fcddc59a1bd67438de136fea SHA512 aa2bcf45f742a9bfbfd08c6091797265bee5ab7ffbec2596f7f2eff43fa3ee52c094aba231130cc329cfca45ef8df75227ea2719d5effb874317e7e2255f0269
+MISC metadata.xml 333 BLAKE2B 38dddf47085838ce106d76a1cf3a89f67e6390948190ee3e218813330a412ccb4b3c0e64c200fbcab0b855d3c2097963703d01044c0dcc55af449fc12da7b549 SHA512 bc4d5e48baa7202f81cab953519e91e41e4670df2ad69173f2d046eb73314e66ef62fe58ea740a71fddf9170570c0fd823a6546fa129a666193cebc389fce153
diff --git a/dev-python/python-scsi/metadata.xml b/dev-python/python-scsi/metadata.xml
new file mode 100644
index 000000000000..601c98379736
--- /dev/null
+++ b/dev-python/python-scsi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rosjat/python-scsi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-scsi/python-scsi-0_pre160211.ebuild b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
new file mode 100644
index 000000000000..768c5c54369b
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 eutils
+
+HASH="957e5538d8d441fb792db6fbbdc0a5e8d57d9c7d"
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI="https://github.com/rosjat/python-scsi/archive/${HASH}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${PN}-${HASH}
+
+pkg_postinst() {
+ optfeature "iSCSI support" dev-python/libiscsi-python
+}
diff --git a/dev-python/python-scsi/python-scsi-9999.ebuild b/dev-python/python-scsi/python-scsi-9999.ebuild
new file mode 100644
index 000000000000..26b967c4039a
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/rosjat/python-scsi.git"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"