summaryrefslogtreecommitdiff
path: root/dev-python/python-scsi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-scsi
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-scsi')
-rw-r--r--dev-python/python-scsi/Manifest5
-rw-r--r--dev-python/python-scsi/metadata.xml11
-rw-r--r--dev-python/python-scsi/python-scsi-0_pre160211.ebuild27
-rw-r--r--dev-python/python-scsi/python-scsi-9999.ebuild20
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/python-scsi/Manifest b/dev-python/python-scsi/Manifest
new file mode 100644
index 000000000000..d944cd829b02
--- /dev/null
+++ b/dev-python/python-scsi/Manifest
@@ -0,0 +1,5 @@
+DIST python-scsi-0_pre160211.zip 126606 SHA256 a86f6cb42fbf45b186fdfbdb697b001dfabf773e698b30dae46815b1aa4f90ad SHA512 43218dfe91eba8f79c0cc7b48e5d7ba3026aac3d0c70dc2d8865905ef70bc479c6a32c46104b3284a00b5832d8893daf4285aac84fd43f1a1ba80affeaf5e258 WHIRLPOOL d44417d7461db3c779805f15311bd51ed0af154237516433ef17a5a23c72c502d6cb09ecf36de913f735a9bc0ce6c4608395167e1e5e850babd3e65dd4ca6c3a
+EBUILD python-scsi-0_pre160211.ebuild 645 SHA256 b6d6dc859f35624b4f24fc03dda49ba28681a85d0c30a6c174d0b13cbe875635 SHA512 f3c5e7ba9c98035ab83bd63f84f76891593c666d43c0cbff9b994512705fed965a38f84b595a778e050559e963a9074b13b30f58658a7811a0384612edba153c WHIRLPOOL 7560f87d05b65c28c9a6f53514823f277b7075bee071b941019b16ff00870eeabf81ebd6fe3d5e623319ef055b8cf61aa9bc1a0350c1b89f55501a1e9e55b10c
+EBUILD python-scsi-9999.ebuild 445 SHA256 e96d1c226b69564abc684d9ada9d79086ee5108125b4eb908e53cb93f0b5acec SHA512 0316ce9f7f4245f2fd9efc70724f2c40d6a92d822427b118d4a5feeb090a9545e76bd8c1083bfcf1207054fb41212e4a9a1918b6c250bc7a28e34040875304ef WHIRLPOOL b32b54a56d5c22391416823eb49f950d0cedf2974168f2ccab9526520b04a6138f874b67bbb3f479d6a62da5a4cb2ac08e5cfebbf91d76655bf0455913401719
+MISC ChangeLog 1376 SHA256 e94dfb04dba3916b113083a10b7a4ea004005e64808169dca0b3c1f0384a3917 SHA512 6757219206306be84a39f1764df967781adc5cb59bc27b366463e64b4eb43b20b94b62fea6d22b34044bdff6c1f272579ba0536e124a825fbd904d5b2b169b55 WHIRLPOOL 0453e37ce2aae6538e717f52346362c67f3601dd3f3909d632c9aa73031ec0f9724bbc3d938678a94d51faea2329d1c0141f8686ed8b9c92e0ef570cdc8f9190
+MISC metadata.xml 333 SHA256 21a891caed4fad9f7eb092389ac1bb1ffb28a703bd32b5012b9c72fbaa9633e2 SHA512 bc4d5e48baa7202f81cab953519e91e41e4670df2ad69173f2d046eb73314e66ef62fe58ea740a71fddf9170570c0fd823a6546fa129a666193cebc389fce153 WHIRLPOOL 2aa16673f14761d337c7f55ec96413f92d1ef23f24c82bc7cc5cc60e4c0b2b0c18f3fbe84a9324e514ba6eda21ce44b38ec958e2a8473de97b1c92978916103f
diff --git a/dev-python/python-scsi/metadata.xml b/dev-python/python-scsi/metadata.xml
new file mode 100644
index 000000000000..601c98379736
--- /dev/null
+++ b/dev-python/python-scsi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rosjat/python-scsi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-scsi/python-scsi-0_pre160211.ebuild b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
new file mode 100644
index 000000000000..8e947c0ffd85
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-0_pre160211.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 eutils
+
+HASH="957e5538d8d441fb792db6fbbdc0a5e8d57d9c7d"
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI="https://github.com/rosjat/python-scsi/archive/${HASH}.zip -> ${P}.zip"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${PN}-${HASH}
+
+pkg_postinst() {
+ optfeature "iSCSI support" dev-python/libiscsi-python
+}
diff --git a/dev-python/python-scsi/python-scsi-9999.ebuild b/dev-python/python-scsi/python-scsi-9999.ebuild
new file mode 100644
index 000000000000..dbdd181f802e
--- /dev/null
+++ b/dev-python/python-scsi/python-scsi-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Access to SG_IO scsi devices"
+HOMEPAGE="https://github.com/rosjat/python-scsi/"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/rosjat/python-scsi.git"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"