summaryrefslogtreecommitdiff
path: root/dev-python/python-rtmidi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 02:47:53 +0100
commitc3a905eafd0ea87d50767fa3d24a6b565a41faa9 (patch)
tree8fcd60c2f36e3da5e4d545f47ddf14680f0d51e5 /dev-python/python-rtmidi
parent159ec3f090554ee5d7f61b2da553833fb7566f99 (diff)
gentoo auto-resync : 26:10:2023 - 02:47:53
Diffstat (limited to 'dev-python/python-rtmidi')
-rw-r--r--dev-python/python-rtmidi/Manifest2
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index 7dba02db290c..f3e0d0aef48a 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,4 +1,6 @@
AUX python-rtmidi-1.5.1-unbundle_rtmidi.patch 1455 BLAKE2B 2cc76ace5758131a069194e9d30c8288ed93a261d41a2b4cf0294e2b4fc7ebee9e0c43b4377143ae8074a03dcc2abf13fd85fdebeebd321efce00e25e43057b1 SHA512 92c11d878018ded30dffa0d06006f8471054321af8d9f58268d4d899121dac66712ddc3a53285c19293fb2d52d4d054b0d803c559e9c01cb8c8f161ce5f2c734
DIST python_rtmidi-1.5.6.tar.gz 367355 BLAKE2B c544669f51e12e82fe38b68e83078ac01463fcff54941c52fad80a1dd3d55985352dea259bad5ba2f70a895a80d5ad55c0249f9ef6fe4e7b81b84582a5855ef8 SHA512 e834159b07fb0b2d05a511ccd2d5b2a86d25f7b0d3a2b92ebe73edf28cd2a035a7aea0460adc6cf6836535da2815ccc0f986731bc9a23bbb19bc7d559d0ef955
+DIST python_rtmidi-1.5.7.tar.gz 368514 BLAKE2B 32028dff34928b1794cc178b22821fe8e01bff36d18b17b8673c763b21ca7ef85a6cb3ee62adcddbaf0b655079e7b8819ba5a28e58b8d5713015728cd6648246 SHA512 23c88cd307b5bc937920db9b39d0423043fb47878d679f4d721a025368a01e23b8e72749e1146da3277d37a20a9c5486e2c40c2a907c5efc5418567e97c3de91
EBUILD python-rtmidi-1.5.6.ebuild 1565 BLAKE2B bc0dde3ce0327ad6a30fda46af7373ade34ec01d2aff0e970b015fe0455915e5d47994b336e89d12f408e90b17f663d29ba6b6af876d9e68b2d2d02ce7a2f084 SHA512 f1617c148c3450782d4c355a572c621e7c8b40288fe55c615c9d4ea71127152979c7372ed0397643b577f097d1b177d557b91e1b0f50551dc18142291f5724a9
+EBUILD python-rtmidi-1.5.7.ebuild 1565 BLAKE2B bc0dde3ce0327ad6a30fda46af7373ade34ec01d2aff0e970b015fe0455915e5d47994b336e89d12f408e90b17f663d29ba6b6af876d9e68b2d2d02ce7a2f084 SHA512 f1617c148c3450782d4c355a572c621e7c8b40288fe55c615c9d4ea71127152979c7372ed0397643b577f097d1b177d557b91e1b0f50551dc18142291f5724a9
MISC metadata.xml 388 BLAKE2B b1bce0f609aae5a298c26c80c3dc3aa33eadf32c9de9da22f4a4f808d1cfd8c769b095d12f2264cf9dd04cdbec8a0fb7202b10c04bb43f9112146023aadd398d SHA512 012ad743d364b9266bef852d159235f27b172ec7fceff43737fe8a67478f991dc53532b021c02d8ffc2eea19cdc568046cf90e440afefb46dcdad275a33f71e3
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild
new file mode 100644
index 000000000000..18e140eddb8a
--- /dev/null
+++ b/dev-python/python-rtmidi/python-rtmidi-1.5.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/myst-parser"
+DOCS_DIR="docs"
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="Python bindings for media-libs/rtmidi implemented using Cython"
+HOMEPAGE="
+ https://pypi.org/project/python-rtmidi/
+ https://spotlightkid.github.io/python-rtmidi/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+alsa jack"
+
+# Most of these tests do not play nicely with the sandbox, some only
+# work with exactly the same version of rtmidi as the bundled one, and
+# several fail even with disabled sandbox unless there are actual MIDI
+# I/O devices present.
+RESTRICT="test"
+
+DEPEND="media-libs/rtmidi[alsa?,jack?]"
+RDEPEND="${DEPEND}"
+BDEPEND="<dev-python/cython-2.99[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-unbundle_rtmidi.patch
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Just in case
+ rm -r src/rtmidi || die
+ rm src/_rtmidi.cpp || die
+
+ # Needed by USE=doc because documentation generation happens in ${S}
+ # but the version.py generated by Meson end up in respective ${BUILD_DIR}s.
+ # The version put in ${S} should be ignored by everything except Sphinx but
+ # just in case, be consistent and generate it unconditionally.
+ sed -e "s|@VERSION@|${PV}|" < rtmidi/version.py.in > rtmidi/version.py || die
+}
+
+python_test() {
+ cd "${T}" || die
+ eunittest "${S}"/tests
+}