summaryrefslogtreecommitdiff
path: root/dev-python/python-rtmidi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /dev-python/python-rtmidi
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'dev-python/python-rtmidi')
-rw-r--r--dev-python/python-rtmidi/Manifest2
-rw-r--r--dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch21
2 files changed, 11 insertions, 12 deletions
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index cc9b91e41419..f85badca05c8 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,4 +1,4 @@
-AUX python-rtmidi-1.4.9-unbundle_rtmidi.patch 2139 BLAKE2B 04782e01de9d01a9f4d44c7f856527173227da94f81d2b7338c1e437194be53d0130bb8b03bd3fdc5b7e71d58f7514f476e817066ce5ce80dd530e78a355e2ab SHA512 d02951fe7f84a9b356765a734bdaa010a56562a86cdc1b54077ad25359339fb299080727f59f95273e842ad537192192f0705806d76f6aaf6022d36a0355ab53
+AUX python-rtmidi-1.4.9-unbundle_rtmidi.patch 2137 BLAKE2B b27c438fa93c00fd458fd8083302838ad0ca96c09c89f0993c6fdc09681f8eccddca53445925c1b437860faa488115d2bc33076a202a5dd730f44cef298c9831 SHA512 6d42f2fe1d533d85ae7ac32b903fc087d4932904905fd778e1979aaed3d4dd6e45db4a49ab87089d67a68ac24b724ef0c7e52eb815badb98d972d3de8cd70677
DIST python-rtmidi-1.4.9.tar.gz 251238 BLAKE2B dda4052e893839f88a6756306f8ff4e89ee66ad9716d374efbb7b92a8e9074e98c8d5df0cc82aa3c6e0c77a78fe9b997079623a5147c03eeea9128dfb7605215 SHA512 91c5a0f807549fbe9d87df6e40b8c3db0f9be753616ba51804900195d02120cd972e39c69dd99e60e4ea1b1d9831d0b956b64ce71b2fe03422efc57bccf5cb70
EBUILD python-rtmidi-1.4.9.ebuild 1168 BLAKE2B 688b922cd52b746cea5ba0b0d747afdf6b43f355f2823c31de653cec500a156f2f8523df34010a3b6b6eba6c77064efea96236bb2be129af51915c603b28266d SHA512 1008bf277276c1daf1dc1a757a190f1bf53497d6618fbaa5f6e54ade77b6ead54b87e5c737f6d9ff8fb835e2096fb5b6058cfbbf0e09d5578f2cd5af6ea0aabe
MISC metadata.xml 388 BLAKE2B b1bce0f609aae5a298c26c80c3dc3aa33eadf32c9de9da22f4a4f808d1cfd8c769b095d12f2264cf9dd04cdbec8a0fb7202b10c04bb43f9112146023aadd398d SHA512 012ad743d364b9266bef852d159235f27b172ec7fceff43737fe8a67478f991dc53532b021c02d8ffc2eea19cdc568046cf90e440afefb46dcdad275a33f71e3
diff --git a/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch b/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
index ecd9f53b108c..45cece4b2eb9 100644
--- a/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
+++ b/dev-python/python-rtmidi/files/python-rtmidi-1.4.9-unbundle_rtmidi.patch
@@ -9,25 +9,24 @@
elif exists(join(SRC_DIR, "_rtmidi.cpp")):
cythonize = lambda x: x # noqa
sources = [join(SRC_DIR, "_rtmidi.cpp"), join(SRC_DIR, "rtmidi", "RtMidi.cpp")]
-@@ -145,18 +145,18 @@
+@@ -145,18 +145,13 @@
if sys.platform.startswith('linux'):
- if alsa and find_library('asound'):
- define_macros.append(("__LINUX_ALSA__", None))
- libraries.append('asound')
--
-- if jack:
-- check_for_jack(define_macros, libraries)
--
- if not find_library('pthread'):
- sys.exit("The 'pthread' library is required to build python-rtmidi on"
- "Linux. Please install the libc6 development package.")
+ if not find_library('rtmidi'):
+ sys.exit("Failed to find librtmidi")
- libraries.append("pthread")
-+
+- if jack:
+- check_for_jack(define_macros, libraries)
+-
+- if not find_library('pthread'):
+- sys.exit("The 'pthread' library is required to build python-rtmidi on"
+- "Linux. Please install the libc6 development package.")
+-
+- libraries.append("pthread")
+ res = subprocess.check_output(['pkg-config', '--variable', 'includedir', 'rtmidi'])
+ rtmidi_include_dir = res.decode().strip()
+ include_dirs.append(rtmidi_include_dir)
@@ -35,7 +34,7 @@
elif sys.platform.startswith('darwin'):
if jack:
check_for_jack(define_macros, libraries)
-@@ -197,7 +197,7 @@
+@@ -197,7 +192,7 @@
# Finally, set up our distribution
setup(
packages=['rtmidi'],