summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/python-redmine
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/Manifest4
-rw-r--r--dev-python/python-redmine/python-redmine-2.0.2.ebuild33
-rw-r--r--dev-python/python-redmine/python-redmine-2.3.0.ebuild20
3 files changed, 22 insertions, 35 deletions
diff --git a/dev-python/python-redmine/Manifest b/dev-python/python-redmine/Manifest
index a2a211531a5e..7cb85a53837f 100644
--- a/dev-python/python-redmine/Manifest
+++ b/dev-python/python-redmine/Manifest
@@ -1,3 +1,3 @@
-DIST python-redmine-2.0.2.tar.gz 559017 BLAKE2B 3bec44ec562f524f7f9b4903e51c1ecaf1f9c7d76e7bbdcd6edd95e7477e9038011336514ea5f75ec23880469331ec5a8b5417d44d032d7440234db1e7bf59ca SHA512 3f8e11315e8e2b4474e8b981bd801ef75857fe73e8ed18d27f64223703d18ea2061416ed38ea35c4a4460a4ccba167b41ab48e2489930181951e9e2a5f53ec12
-EBUILD python-redmine-2.0.2.ebuild 906 BLAKE2B 063868e8683617a2acab0575cf9bfabc26e691f4f7cff9a863264d6fc6ab5f86f34caacb7de3c44e84acfb9691412daa01d26a418f8ed89e203a2376e5c7e300 SHA512 ae0f7b365f4b4eb972081b0e0c99dc19fa5be28ef105d2a3ffdc2a45a1ebbf4d11567236a0171a7d5150acce758777fdf11d7aa37ff45dc39348ca8b1f33d3ae
+DIST python-redmine-2.3.0.tar.gz 67915 BLAKE2B ad31d63ec5bebd33ff436f04c40fd49e35a79751c353ba1e343bbb03048c2d1662ec8ffea5819561b675e366f8cbad48a0e0a0a59dcaa563a90301ad4f1eb1cf SHA512 a317743a561cde65c17356a317d3aed082149d648aaa7487858c8533ceb286d08b6610d742321f6593fef8b61b1a4526963ddffc4ab180a83795d66773154b70
+EBUILD python-redmine-2.3.0.ebuild 473 BLAKE2B 16f551d804516563452c06c14c7363e71215fba691dc71eabdaebce599d8eaf5f3d57c2121d3e7b65433d9c49d680f8f916159705902298e2e39f3316d0c60c1 SHA512 0215667a40d27cf3d354cd90dc52d80bc58aa06a5f3c0383d92efe114e53427c39e8f8643101666253f51415bd592fdd98b14ab4c5c4ef445e20ebf40ca5932b
MISC metadata.xml 400 BLAKE2B 03f628bb2d3dc4fe61613c08dff75e0534c475d637150a9c895e23e613b5c32188f78b298fb1b754d0df6e617f5d7c28e5e20f1984fe297a6d550b2debfe290b SHA512 12d43f2ec4712a7c01ed86aa2b1d05eebb907a8a6bd787ec82aff8ea2a97cc6708255dfad3d386550bcc72887d1b273b6ff3f958bc22e5bbdc4bd8a8d28a57ac
diff --git a/dev-python/python-redmine/python-redmine-2.0.2.ebuild b/dev-python/python-redmine/python-redmine-2.0.2.ebuild
deleted file mode 100644
index 403396ebdefe..000000000000
--- a/dev-python/python-redmine/python-redmine-2.0.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to the Redmine REST API"
-HOMEPAGE="https://github.com/maxtepkeev/python-redmine"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-
-distutils_enable_tests nose
-
-python_prepare_all() {
- # Remove the bundled copy of dev-python/requests...
- rm -r redminelib/packages/requests \
- || die 'failed to remove the bundled copy of dev-python/requests'
-
- # and replace its local import statement with a global one.
- sed -i redminelib/packages/__init__.py \
- -e 's/from . import requests/import requests/' \
- || die 'failed to replace the dev-python/requests library import'
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/python-redmine/python-redmine-2.3.0.ebuild b/dev-python/python-redmine/python-redmine-2.3.0.ebuild
new file mode 100644
index 000000000000..493cc6814736
--- /dev/null
+++ b/dev-python/python-redmine/python-redmine-2.3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the Redmine REST API"
+HOMEPAGE="https://github.com/maxtepkeev/python-redmine"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/requests-2.23.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests nose