summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 22:13:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 22:13:48 +0000
commit97975d199eba29b1b2f09f99dcd0566f2d1f581f (patch)
treee745f623575a90f1608f613dedfc4e441092909e /dev-python/python-redmine
parente65ee315554600740a3ecc9dde351e7ded136023 (diff)
gentoo auto-resync : 05:11:2023 - 22:13:48
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/Manifest2
-rw-r--r--dev-python/python-redmine/python-redmine-2.4.0.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/python-redmine/Manifest b/dev-python/python-redmine/Manifest
index 073c92290be5..68401a143463 100644
--- a/dev-python/python-redmine/Manifest
+++ b/dev-python/python-redmine/Manifest
@@ -1,3 +1,3 @@
DIST python-redmine-2.4.0.tar.gz 67730 BLAKE2B 22c74ad194af9b56affab39de38b13a8f5a46e79b8ea8d9f9f47eb12c4ad4c91156db9ef0e8dfd013602b8cc06e0636a724ae34969f385dc9f8ffc63514ccc63 SHA512 afb03ca8a3bdacace3c12b7295ba08953ab2040971b57988deb9955df24e5ac1782a9b3fbf0f5070eb22c640e88f489cda12cdec38449f9e3bcf7189dc422642
-EBUILD python-redmine-2.4.0.ebuild 570 BLAKE2B 04a7065f9d8a355f4669fc992f888348235e8b370d7133a3503bff0801c9ff369dc5b34c8cb417b34ad4b8ca51f80d7ad69f7f4bdf97d4ea77652f0625598172 SHA512 cc4c9dc3c6703cadf3566630cbfa61a5845a9c8a451b8fc17cc8f7f4aa204c1861ee23e43abf39da8583a30ecc097ea7a1a467af8e04b31338a5956265a1a5cf
+EBUILD python-redmine-2.4.0.ebuild 732 BLAKE2B 267d443ceb02acf6f6c5e1d1be819bc3b661b97019ab9b6378c4f1002a192a1128a38408758e340cd629abe3b1e20051b9dc17febcd9f5ed1348bc030a84b656 SHA512 5c9eb830f386b10aaa3f779f9bad092326c6963e9ed76a422bda0fced0dc2bc96f7723f66be4313947fafc9f63f8e1622b04965c71978b4f56a1433a90e1687b
MISC metadata.xml 426 BLAKE2B 4b854d12e2cd5977800ee0ba114e1e8cf3895afc412d50b7ca9101842c3430a076e8daa07ae58624e3ae25163cf49de5924f9df7735550903f79ffbebbdd3763 SHA512 e56e41d36e3fbb82ec4b592ec3c6b4a69669bf79c159a97045b7643676361208885ec18a0dfd2462a8f456435d5ec51250b893693f9411c727e8bd44c8a4ae92
diff --git a/dev-python/python-redmine/python-redmine-2.4.0.ebuild b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
index da55d3bf3c50..1492e5810aa4 100644
--- a/dev-python/python-redmine/python-redmine-2.4.0.ebuild
+++ b/dev-python/python-redmine/python-redmine-2.4.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -25,6 +25,12 @@ RDEPEND="
distutils_enable_tests pytest
+src_prepare() {
+ # https://github.com/maxtepkeev/python-redmine/pull/332
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
+
python_test() {
epytest -o addopts=
}