summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine/python-redmine-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 02:13:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 02:13:31 +0100
commitde6c40224da664deb650b25efd11f41044602c76 (patch)
tree705e4bb63436ed72cbca7e1a3aac31778933cff7 /dev-python/python-redmine/python-redmine-2.5.0.ebuild
parent54135f54d50ccd967032395ba30074c9d46dab25 (diff)
gentoo auto-resync : 01:04:2024 - 02:13:31
Diffstat (limited to 'dev-python/python-redmine/python-redmine-2.5.0.ebuild')
-rw-r--r--dev-python/python-redmine/python-redmine-2.5.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python-redmine/python-redmine-2.5.0.ebuild b/dev-python/python-redmine/python-redmine-2.5.0.ebuild
new file mode 100644
index 000000000000..8219293367ea
--- /dev/null
+++ b/dev-python/python-redmine/python-redmine-2.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface to the Redmine REST API"
+HOMEPAGE="
+ https://github.com/maxtepkeev/python-redmine/
+ https://pypi.org/project/python-redmine/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.28.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # https://github.com/maxtepkeev/python-redmine/pull/332
+ sed -i -e 's:assertEquals:assertEqual:' tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ epytest -o addopts=
+}