summaryrefslogtreecommitdiff
path: root/dev-python/python-ptrace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/python-ptrace
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/Manifest4
-rw-r--r--dev-python/python-ptrace/metadata.xml19
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.9.8.ebuild32
-rw-r--r--dev-python/python-ptrace/python-ptrace-9999.ebuild31
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/python-ptrace/Manifest b/dev-python/python-ptrace/Manifest
new file mode 100644
index 000000000000..5ecaaa3f31a1
--- /dev/null
+++ b/dev-python/python-ptrace/Manifest
@@ -0,0 +1,4 @@
+DIST python-ptrace-0.9.8.tar.gz 104079 BLAKE2B 3d387beca9c92c0e3bbd5cf2c9d2af447c233b631e894ce1af2cdc697a1a48e24a299bbc998cd187ac9ad0f45bfc886f476afdb69329d761e8730a047731126b SHA512 f50ba7d457bf20a161a99913a552f2e829e97975d7cfbf8cf5d89b4f2320772b537678f2e70b9aaa88341c4f01d4bf41f62683e913628db503152f3510a013a3
+EBUILD python-ptrace-0.9.8.ebuild 711 BLAKE2B 4671311f3170342ab4aa0cfa2aebea4cc9a3e7e582939b36fb2f293fb3098ea4c1051eae02b9e118cbf89acb2b2faf220b0edca0e4e9996bf1ca24d59d7ed40c SHA512 1a982e3c59e605fd3c16d1d28df5dc74d9d11dfe8659d8f379664ea679f8b69e4f8bfd82be11bdedca82552f1cdbde6bbb48ceb06b8b320ba261591584092db2
+EBUILD python-ptrace-9999.ebuild 680 BLAKE2B 15cc0d82169e51bf51139a47669eeb3ceda9d07591a769331f6e76a5d87411f18f500941ebae09c4bb0c1f4a4b5ca8897a6d209b01a8156abd8b5c9dfdfbd541 SHA512 3a8137451ba0af29b4544af22c2e4fb68500a8323f3f07c1f24e32b42cc7c51a0a0025b723eab31fc308620279d160b1d96d0bc7cbacf2c9f85adb47229edddc
+MISC metadata.xml 623 BLAKE2B e65db6770448631a0d3f54edac2fe84163a165939245caf020371eeae4f0f4c77a6ae79c14b92391f65b8a315f33946f0045d1771ff2a256e0e5ff550b72a7a2 SHA512 cde30b944c24bbea008e7bb0f7a357b76be54418d067a83c5cff55252a147670de45918318741076925fc04ab1a6f4f320a3f9b328bcf45b9adbdd8683324ecb
diff --git a/dev-python/python-ptrace/metadata.xml b/dev-python/python-ptrace/metadata.xml
new file mode 100644
index 000000000000..c5f4fb2ed06e
--- /dev/null
+++ b/dev-python/python-ptrace/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mario.haustein@hrz.tu-chemnitz.de</email>
+ <name>Mario Haustein</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <longdescription>
+ python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system
+ call to trace processes) written in Python.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vstinner/python-ptrace</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild b/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild
new file mode 100644
index 000000000000..a97f40f69773
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.9.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python binding of ptrace library"
+HOMEPAGE="https://github.com/vstinner/python-ptrace"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
+else
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ ./runtests.py --tests tests/ || die
+}
diff --git a/dev-python/python-ptrace/python-ptrace-9999.ebuild b/dev-python/python-ptrace/python-ptrace-9999.ebuild
new file mode 100644
index 000000000000..c87c6168a30e
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python binding of ptrace library"
+HOMEPAGE="https://github.com/vstinner/python-ptrace"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
+else
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ ./runtests.py --tests tests/ || die
+}