summaryrefslogtreecommitdiff
path: root/dev-python/python-ptrace
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-18 11:05:42 +0100
commit1426dfeb15e4d49cb4238c6cf37455a6130cd83f (patch)
tree9f9734bcdc280108e52d753b3c57234371772c3c /dev-python/python-ptrace
parent836586553c510ee2dd91e2ecd7676fe432c1f1a4 (diff)
gentoo auto-resync : 18:09:2023 - 11:05:42
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/Manifest2
-rw-r--r--dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch30
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild36
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/python-ptrace/Manifest b/dev-python/python-ptrace/Manifest
index fe4c47745249..07b8a2fd36cf 100644
--- a/dev-python/python-ptrace/Manifest
+++ b/dev-python/python-ptrace/Manifest
@@ -1,4 +1,6 @@
+AUX python-ptrace-0.9.8-python3_12.patch 914 BLAKE2B a0e4f4dee0baf98e398c8618d92fb5fe60817ed4dea0f577795017c2ad3ae89b1936045d65c161b104169ab3f786d824a5038f0a078452bbae265588b621b4fd SHA512 2b9470247ee6ea92bf20402f51595b4aba43f4c3b85db13b701cf7aefe52f28f4a1a7d122e4422217286363c8b05d338e671c99cca55c9bdae3d993c42a43578
DIST python-ptrace-0.9.8.gh.tar.gz 104079 BLAKE2B 3d387beca9c92c0e3bbd5cf2c9d2af447c233b631e894ce1af2cdc697a1a48e24a299bbc998cd187ac9ad0f45bfc886f476afdb69329d761e8730a047731126b SHA512 f50ba7d457bf20a161a99913a552f2e829e97975d7cfbf8cf5d89b4f2320772b537678f2e70b9aaa88341c4f01d4bf41f62683e913628db503152f3510a013a3
+EBUILD python-ptrace-0.9.8-r1.ebuild 765 BLAKE2B 4dafe44e983c22d908843ba47637ed4680428393475ba266095736622e05865fab504b3f99066ea08c2ea158a3852bdc460e56af4dd2f4d2da647b0dfc885deb SHA512 d213594c545121e286a144c33f0d0503880c2529634e885347ea49341c24606410f3793363eb685ab453ea71debefdb7a073a92e2b793f32152fde1703ecfba7
EBUILD python-ptrace-0.9.8.ebuild 712 BLAKE2B d3ade6103844969fba7d7a91fd380361556a1eef16461bfdf352dd8e88a6ed2d51acf199396f6335607d95519a3e83ab59a97fa7535b351887fa9b1dbcd87c76 SHA512 4a06dd68e4de3b0f45a07f79f6e80026d861895acdac9df839b4023d4615f8a06df3e6e876d7b0636b05db92ec67c8dcd3b9343b267c238d60a93f72581d1d3e
EBUILD python-ptrace-9999.ebuild 714 BLAKE2B 4fb5fc31dcc2a7ee44b66610753f5dda1615e49caa19b008236a6375b53e6037c2ed9701f318f02baedf840a9b825b482d6ef6470e7a68119d76d5cdc282efc8 SHA512 e088c4e2f360069b4182ad2ff8eb8dfb80734ec3bc608f4f5d2bb1cfc7628715ac33f093a9b57343a568bd1ee3307f042e1176a33298c3df3dcdd825d4422f85
MISC metadata.xml 674 BLAKE2B f247cbce73a3bc785c4747c79a4fa99867dd75255d3a18f91de90179019ac2ef2e85da096107029d8f50f4565dcae14e1bc26e91f7ab882fa6cc9572ee8743a4 SHA512 08dca730bfc844e8ec06bd0d7914c23d8f74d1ebc54e22b99206de5240bd256d30dfe702cac9c3825b283be55be8a0111fc2f24482186f4b7bb24c6bc8369f94
diff --git a/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch b/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
new file mode 100644
index 000000000000..fc7e55f6160e
--- /dev/null
+++ b/dev-python/python-ptrace/files/python-ptrace-0.9.8-python3_12.patch
@@ -0,0 +1,30 @@
+Upstream: https://github.com/vstinner/python-ptrace/pull/81
+commit 80e0c97a84eccb8b82737cf40b9c5581c20c245f
+Author: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de>
+Date: Sat Sep 16 13:49:43 2023 +0200
+
+ Remove deprecated `imp` module
+
+--- a/setup.py
++++ b/setup.py
+@@ -28,7 +28,7 @@
+ # - git commit -a -m "post-release"
+ # - git push
+
+-from imp import load_source
++import importlib.util
+ from os import path
+ try:
+ # setuptools supports bdist_wheel
+@@ -55,7 +55,10 @@ CLASSIFIERS = [
+ with open('README.rst') as fp:
+ LONG_DESCRIPTION = fp.read()
+
+-ptrace = load_source("version", path.join("ptrace", "version.py"))
++ptrace_spec = importlib.util.spec_from_file_location("version", path.join("ptrace", "version.py"))
++ptrace = importlib.util.module_from_spec(ptrace_spec)
++ptrace_spec.loader.exec_module(ptrace)
++
+ PACKAGES = {}
+ for name in MODULES:
+ PACKAGES[name] = name.replace(".", "/")
diff --git a/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..a9819a317788
--- /dev/null
+++ b/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python binding of ptrace library"
+HOMEPAGE="https://github.com/vstinner/python-ptrace"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
+else
+ SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python3_12.patch"
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ ./runtests.py --tests tests/ || die
+}