summaryrefslogtreecommitdiff
path: root/dev-python/python-prctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/python-prctl
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/python-prctl')
-rw-r--r--dev-python/python-prctl/Manifest2
-rw-r--r--dev-python/python-prctl/python-prctl-1.7.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-prctl/Manifest b/dev-python/python-prctl/Manifest
index 620cbd7ddfec..77a6492c3917 100644
--- a/dev-python/python-prctl/Manifest
+++ b/dev-python/python-prctl/Manifest
@@ -1,3 +1,5 @@
DIST python-prctl-1.6.1.tar.gz 25788 BLAKE2B 48cf4b8f9bd50c0619218fca889f1d83c001a07d914bfd6cd61596957a467165cc8738abeaa0671ba32e90c46d8a96b56aca8443837e45e8bba6815a11463e72 SHA512 9d379f2082523421b69f237042826fb4360d1da6e96dfc3f7e5133cb7041da4e3ea9954b14a063967c6dca2a766d39fbfe7eda71df13ae38ce046ec102949f3a
+DIST python-prctl-1.7.tar.gz 25922 BLAKE2B 2d0ccc2174c62a74fcffec1115f3d157b6579c8f7dc138aacecc2d7ee479d71954b04cf1f7d881c1212d1f63c22aad800db07756e2803de2deac7eeb5d0d2742 SHA512 f2a18fc8e9ef469722c6618d5dd6b7b558d4060783e6fb3a8dc868d9ed3fa21ade371f94a4538a24dca92a71f623a96638c96882d9cf0d3d499a9f12dae8538a
EBUILD python-prctl-1.6.1.ebuild 499 BLAKE2B 67e28211d06f8192e21b642afb4e05cd953b1dc16faaac657985c36c662daa2aa0119d9cd924129fc152ec44afd4682e68ec7c918bb21b146531ec768e00e14a SHA512 8053f8a206b0b475de487c834c130970d5215068e29239063d16bc29dacee2048322ea554c162f15028b4abf971baa591b669690faf69c64b639745d5175bf74
+EBUILD python-prctl-1.7.ebuild 503 BLAKE2B 448b664bc73f057f59fff2f60e049b83c37bbffd07e0e76acd0edfb47c38ebc3048ccdca9a9b26c95508e75bf78b0c4945bf5c3baf0ea297b968c218cbc11534 SHA512 47f148ad66d197c7082db50890ea63dbe19c7e1e03dacfdd75aaf55fc1f5a51a2a35e3abbc8554a6a7f8a492711ee0a842fd688c9ec14f7df304d5dad36de9b7
MISC metadata.xml 334 BLAKE2B 1fc3c650f15c0c5663110d323f0a4acf970fa31ef8711ea894b6440bd7b04d37d2465db26168833e45bc728f6732f15352f1125d30d85ff16b9d2275931e0818 SHA512 42e6bed26bbf277f03865d151148646a4077baf61256e67616f04f004b807bc5bcb5122bded7a20d05f1eb57a2850cf0f31e469f3482c0dd214fd408b6494cdb
diff --git a/dev-python/python-prctl/python-prctl-1.7.ebuild b/dev-python/python-prctl/python-prctl-1.7.ebuild
new file mode 100644
index 000000000000..47d8ce68b2aa
--- /dev/null
+++ b/dev-python/python-prctl/python-prctl-1.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/libcap"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"