summaryrefslogtreecommitdiff
path: root/dev-python/python-prctl/python-prctl-1.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-prctl/python-prctl-1.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-prctl/python-prctl-1.6.1.ebuild')
-rw-r--r--dev-python/python-prctl/python-prctl-1.6.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-prctl/python-prctl-1.6.1.ebuild b/dev-python/python-prctl/python-prctl-1.6.1.ebuild
new file mode 100644
index 000000000000..14554209c2c9
--- /dev/null
+++ b/dev-python/python-prctl/python-prctl-1.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Control process attributes through prctl"
+HOMEPAGE="https://github.com/seveas/python-prctl"
+SRC_URI="https://github.com/seveas/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/libcap"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}