summaryrefslogtreecommitdiff
path: root/dev-python/python-poppler-qt5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /dev-python/python-poppler-qt5
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'dev-python/python-poppler-qt5')
-rw-r--r--dev-python/python-poppler-qt5/Manifest4
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild21
2 files changed, 16 insertions, 9 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 16b48eb61af9..bd6bb05e2338 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1,3 +1,3 @@
-DIST python-poppler-qt5-21.3.0.tar.gz 25641 BLAKE2B 5937f1ddc1493bb1ef1d98b91dd8ccec4bd8c835956d84c8d7ce7a1cedcbe16854861e1f13825812e0f74c335020f0d74aad2d2bbc7a5780c6eb3ac77437f13b SHA512 cc942a860c2c999ff04fb0468b1556b0e23e7aa19a0185a39c5e903e717dca64bcbd51b8fe34b6885bd789cbf5cc1080c2ca1dcee30b3e69fa1721618e8db278
-EBUILD python-poppler-qt5-21.3.0.ebuild 744 BLAKE2B 1f8e3727d41503a6e403353c6fdd1d6289b83f2d44ba8d547a9863d753a59f3eff7662b6bc9065c0fc9a81cfd65be0fa06cee446135a0f976bfb369ffeafa87c SHA512 05a2cdaa66e898928e153feefb3879e94854c7158cb9a0eaaccaff587948efe194c9c5a787b23035c040440fc8df949e1919055468b0b1a64541bb0bcfa9d74e
+DIST python-poppler-qt5-21.3.0.gh.tar.gz 25641 BLAKE2B 5937f1ddc1493bb1ef1d98b91dd8ccec4bd8c835956d84c8d7ce7a1cedcbe16854861e1f13825812e0f74c335020f0d74aad2d2bbc7a5780c6eb3ac77437f13b SHA512 cc942a860c2c999ff04fb0468b1556b0e23e7aa19a0185a39c5e903e717dca64bcbd51b8fe34b6885bd789cbf5cc1080c2ca1dcee30b3e69fa1721618e8db278
+EBUILD python-poppler-qt5-21.3.0.ebuild 808 BLAKE2B 5786b38c05d30682559f50ddace63f418543ed11ec9327d87b301ea4af7d7f0e0b98e370de4754d3e5f7f680fa43bf09bfcdf432c1f844fcba2de61e52a38134 SHA512 eb9fad54da5dcaaaf554e30cd92e1a5dc62f616979a94ceb7272bccafdc270f18027bcf59a98b26cb21c27e4b791381e5a792a46d1eab37b4f434cc6f2651fa3
MISC metadata.xml 392 BLAKE2B 51992d04b5914b5248871f36659a45176628fe6e45f78b75ad1f64dadcbc5e2606a022498125cefcad2526a43b88e92dd115592b413b86245083fca038611fcb SHA512 6b356062a520973b99990be8f40ff7a5f705089988ebe889a09829fad92ff42d6ec4cddc406f39c6bb19bbf0d6c231557fd350348721c2d9feeb0d4808fc27fd
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
index fe358ef69dac..cfb68d7001d9 100644
--- a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=sip
-PYTHON_COMPAT=( python3_{9,10,11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing qmake-utils
DESCRIPTION="Python binding for libpoppler-qt5"
-HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
-SRC_URI="https://github.com/frescobaldi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/frescobaldi/python-poppler-qt5/
+ https://pypi.org/project/python-poppler-qt5/
+"
+SRC_URI="
+ https://github.com/frescobaldi/python-poppler-qt5/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="
+DEPEND="
app-text/poppler[qt5]
dev-python/PyQt5[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
src_configure() {
DISTUTILS_ARGS=(