summaryrefslogtreecommitdiff
path: root/dev-python/python-poppler-qt5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/python-poppler-qt5
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/python-poppler-qt5')
-rw-r--r--dev-python/python-poppler-qt5/Manifest2
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild23
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 551aadc0e672..060443e1cd4b 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1,3 +1,5 @@
DIST python-poppler-qt5-0.24.2_p20170214.tar.gz 20676 BLAKE2B 450f1f40618686f393a21bb2f9ae25b71ab31b4270420a278c65dfdad722a7505cab50d17968400304df936f8694a7d2d5aafeac355675756ca70271f3ff666c SHA512 28fbc4584d32ae18a0545beaf2954f89da6aaa5c2d4bbb25dc36996dd5799c38c491254330c5ac12f3a97df33656f1b49bcb672207602031ff37086a08cbb1fc
+DIST python-poppler-qt5-0.75.0.tar.gz 23281 BLAKE2B 06b2b0899d2a3cfc84e623b98cc3379aa45ac9ca9267f25168cce04f2ed761fd897043376fda3386b2daff2b46850b24782cafd6aabb13a8e7d6f3920b55a02c SHA512 2f03036a2eaeb8e28875f19a813ff85a91c1e9a94301bdb736ecc50e7ececb4de2622728e6fecbf64e114435529f82b6afd23d772e2d3910ae03d5d2b5da3205
EBUILD python-poppler-qt5-0.24.2_p20170214.ebuild 753 BLAKE2B 8887b16452fba594c7d64c6362483af973478a34da638f22534615d0d3a086f2fb5c158ac2802091b4daeddea01d4bab12258437a36ed81e51213353d53fcfa8 SHA512 44a9bebdcc8d4ca8eccc7a38e94462a8e6a3a030bdade04ff53ce6168b5d957d23fce2c261a3108bbcff74926afab43e4c349f31871dfc779623d6cb21cb60c8
+EBUILD python-poppler-qt5-0.75.0.ebuild 547 BLAKE2B b0a9a2f4a0df653c9552a73f00e5f38f99035ed08ad29d2edde975a6b2720430e6ddd9e3a788c66aed7173ad3bb7bd321d76a443cf38d9f3d66d84087becd8c2 SHA512 ce37c28ee6b37b1e369c657e5ca8fc7bdc2af25409a056ff8bfdba8d3048b60b1f7c9eeccb7e29ef152f4c855287cba8da0737c972a96b294d6196c897fe7b44
MISC metadata.xml 330 BLAKE2B 8ec299c2f0c45f1e6f1c0da00c43ea51ae4b93117b5c1fa29d31692e8b7b553c9f977f54bc379fd01addcd682a2a357670696972e953410972d1cafa670cc1cf SHA512 5ceefef72bdb03860d693c39df292964f2a81f477a872541ec2430062cadd5ec945c9e60ae7b157bdfea804016d3d5aae1ccd19c6fa75a3a86bd9ce3e4f30f14
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
new file mode 100644
index 000000000000..8c4bc4642a8a
--- /dev/null
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python binding for libpoppler-qt5"
+HOMEPAGE="https://github.com/wbsoft/python-poppler-qt5"
+SRC_URI="https://github.com/wbsoft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"