summaryrefslogtreecommitdiff
path: root/dev-python/python-poppler-qt5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /dev-python/python-poppler-qt5
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'dev-python/python-poppler-qt5')
-rw-r--r--dev-python/python-poppler-qt5/Manifest2
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild15
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 7b654597456b..78d74ed78e01 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1,3 +1,3 @@
DIST python-poppler-qt5-0.75.0.tar.gz 23281 BLAKE2B 06b2b0899d2a3cfc84e623b98cc3379aa45ac9ca9267f25168cce04f2ed761fd897043376fda3386b2daff2b46850b24782cafd6aabb13a8e7d6f3920b55a02c SHA512 2f03036a2eaeb8e28875f19a813ff85a91c1e9a94301bdb736ecc50e7ececb4de2622728e6fecbf64e114435529f82b6afd23d772e2d3910ae03d5d2b5da3205
-EBUILD python-poppler-qt5-0.75.0.ebuild 555 BLAKE2B fb77a00c55ae8ba813ae43789a4cd277381274b6ecd8cec3851f59c8c35b7d57424520dacb72c8f3ac2a75803725ea8d35437dd9d0c8129b669f18f63218540d SHA512 f2937553bbace634cf7c02ffad905dae751425928ef18171c1305d51fde41af686f3682be0fd73d204c78d7d8549e9629c7ebf5748cec26c1194b07b9caa4353
+EBUILD python-poppler-qt5-0.75.0.ebuild 754 BLAKE2B 3feff3a0a52b31aa48a8113d19d3057d46cb87009673c1aa5cb9fa0a16646a53788a41eaffc41833976b2cc91491a124b702cc02a400b8de859c2eeaafcfa472 SHA512 2c8bd878b15dd675e60a4093f2fe71814b2527d6e8c300524e90e38ed5f6a1f51d5d55fa08920acc1f763afb74918645f75361fddef7eba19bfd447fd2200544
MISC metadata.xml 391 BLAKE2B 6c73b8dafe3e3b3574bc0825c16d16ee82e24f88ad987e93f8647caba0b8ca2b0bc23109734b7cebfc7e3419e404602802283ddc6922d27f556c787660668bac SHA512 9aa4c05abf4581e9decb8fa3764311a3c86de6cd9cced72ac44d6c49e9c6ca722f6adb85994341d951b3bfa6ab719325de40073d1c09a9580f51406db1730549
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
index 966751ccba3f..e737b69a306c 100644
--- a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit distutils-r1 qmake-utils
DESCRIPTION="Python binding for libpoppler-qt5"
HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
@@ -21,3 +21,12 @@ RDEPEND="
>=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+
+python_compile() {
+ distutils-r1_python_compile build_ext --qmake-bin=$(qt5_get_bindir)/qmake
+}
+
+python_install() {
+ export PATH=$(qt5_get_bindir):$PATH
+ distutils-r1_python_install
+}