summaryrefslogtreecommitdiff
path: root/dev-python/python-podman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-20 19:28:42 +0000
commit032a3dbb5d4ea63ec6c2ceb39c067ea6424b5792 (patch)
treed46be9dbc767750a192f7a4d505757f2eec582f3 /dev-python/python-podman
parent6ec19c7f1bc4aa70e5f8a86cd29d579a95d97035 (diff)
gentoo resync : 20.01.2020
Diffstat (limited to 'dev-python/python-podman')
-rw-r--r--dev-python/python-podman/Manifest4
-rw-r--r--dev-python/python-podman/metadata.xml3
-rw-r--r--dev-python/python-podman/python-podman-1.6.0.ebuild30
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-python/python-podman/Manifest b/dev-python/python-podman/Manifest
index 80829eda5474..a26a3d89118d 100644
--- a/dev-python/python-podman/Manifest
+++ b/dev-python/python-podman/Manifest
@@ -1,3 +1,5 @@
DIST libpod-0.12.1.2.tar.gz 5987875 BLAKE2B 11381c53e768c94bfadcb2013a028f64058b0001cd985ef289d1618163225cdf10bd608cff0cd6f7fc1c094497184fc6d0cedea32fde54f3581ebb51eb5eabdd SHA512 9abb46d7880c4577d22b48aed01baeae29662dc3dbbdbc297f1eebe8324fb734d9bac6cd105dc93f7600753874c0fa581142d1b16f7490175cea80b8f62b34ce
+DIST python-podman-1.6.0.tar.gz 28733 BLAKE2B ef36b80d99be07def311c2a8574cc36131760b39f0c80fb8707fb99ec9c2234e297724fc662f936217f9c2ec24fed0f57fd680702fbbac0e8411fc7c90da0577 SHA512 e7d730f8cfef0944df82ee73edb858e3cfd76a91dace98a2638341a1eb3ba5b9076d52f2f634cb4a94e082a83553412cdb1c5b79041d5bf4615998d67bb4a03f
EBUILD python-podman-0.12.1.2.ebuild 797 BLAKE2B 5faa8f22b0bbe7572775be626222fdf783ae0434b042c47a4d0828b4a3c4cc395aece66303a28487ab2a799a3a96898ed056ea6f00fb13bc0196575e211b6258 SHA512 fd02bbea4fad5f6e488a1692892bff9897dc4aae30002cac9b8b9050cb4e8c0e4b0a0a432a9d752e37762f2ea87428618cb212a700e6fb78047d44b3a56c5bab
-MISC metadata.xml 326 BLAKE2B 77218bd50d76e0dd8ffbeb168b7e08d7cea7f8768f9d552865fa85f7ae78b9e4654fcb672320776b28b013e592117a4289522bdb0a62f03f40523b78d36f6171 SHA512 2d777f25c03c813cd1ec96215d91dd793350d48ba396de9c544a53412401b313ee5270311612e4a13a2b1a318591ba7fd96db686d639e241c13ac432808f219e
+EBUILD python-podman-1.6.0.ebuild 838 BLAKE2B b3599370798d1864c3ab07e451e98d6fc8daa27257e6518c9d0c0801f0350a0a90fd3c00828dd0403e06bed41b15929d7cfdc35b84dbfb3af81900d3cf1fe199 SHA512 eab6205c808bb84100abc176ef20935c52acbbca96cc9335b2a9cfb17753c42141a295fbdad511df24ec71a742d3b66e053b4d05ce09b6944e7d7494b7650ab7
+MISC metadata.xml 377 BLAKE2B 75e5283150b5ef215448569254a4707ed648adc52a99664775fb21e1d49c4a0af6b6b559c5829aa759a20412a0f36b73a28b3375e5310b76a2648652e82e6fce SHA512 db373251d8bcd61548e6f173f071b399f93f253d311195f74ee2a07ac0440d934a7b5a1f838a8629f986dc6032780a5bc0be3b6665127d610fd7fd28586f143f
diff --git a/dev-python/python-podman/metadata.xml b/dev-python/python-podman/metadata.xml
index 7d1075feff13..1264cba62cca 100644
--- a/dev-python/python-podman/metadata.xml
+++ b/dev-python/python-podman/metadata.xml
@@ -6,6 +6,7 @@
<name>Zac Medico</name>
</maintainer>
<upstream>
- <remote-id type="github">containers/libpod</remote-id>
+ <remote-id type="github">containers/python-podman</remote-id>
+ <remote-id type="pypi">podman</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-podman/python-podman-1.6.0.ebuild b/dev-python/python-podman/python-podman-1.6.0.ebuild
new file mode 100644
index 000000000000..d08d17805def
--- /dev/null
+++ b/dev-python/python-podman/python-podman-1.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="https://github.com/containers/python-podman/ https://pypi.org/project/podman/"
+MY_PN=${PN#python-}
+MY_P=${MY_PN}-${PV}
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-varlink[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-39[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ "${PYTHON}" -m unittest discover tests/ || die "tests failed with ${EPYTHON}"
+}