summaryrefslogtreecommitdiff
path: root/dev-python/python-pluginloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-python/python-pluginloader
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-python/python-pluginloader')
-rw-r--r--dev-python/python-pluginloader/Manifest3
-rw-r--r--dev-python/python-pluginloader/metadata.xml11
-rw-r--r--dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild20
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-pluginloader/Manifest b/dev-python/python-pluginloader/Manifest
new file mode 100644
index 000000000000..cc73ad59cca6
--- /dev/null
+++ b/dev-python/python-pluginloader/Manifest
@@ -0,0 +1,3 @@
+DIST python-pluginloader-1.0.0.tar.gz 4625 BLAKE2B 6da2fe78d09943e56df8331c3c0ca399f6e29d10c38c1408d49954cf2f272fa0876391f27b5553a0183541ee642570a47af97c17f441b4f964721dd2fecc1b10 SHA512 879ff3eb1ff9280a4a580f24903b4f449910ec34b7e3b08215c86cc81e9c65ec48279143ac0ed8564478d1c013074c8165f6a85b43bf08760c83dda78a19f246
+EBUILD python-pluginloader-1.0.0.ebuild 444 BLAKE2B c01efcb22ad8c8fc854782fe686ae4e9917391a363d5d76521595e69f34ad603d4811229c7c9034c58d45719e11e4b71d1314e1a4e96771d777c59e4df7aa65e SHA512 b85f217ab990d39e7fd4f0cfbdca4e4f4360334b18af5565f91f58b7d2c56a49e2e815e8f79a3d362b5bedf26915143d00166fea5cd42b0bda654dbc4faef088
+MISC metadata.xml 331 BLAKE2B b3da4653d8bd6617ad3d8b91ebab4d324de3d753f59b2b8cd84bfa92c26fbc5e2662f316f19254e9bf8edba4111a4c575b3b8145760bb4cf98cb1e64fa12de93 SHA512 339d7ec309d557c0775177f7da3940218c56c2f9b09797a9398471fd07f23096e062febcc66292e713d4c62e36061c11532e3fc268e097e143cfbeb6b1edca62
diff --git a/dev-python/python-pluginloader/metadata.xml b/dev-python/python-pluginloader/metadata.xml
new file mode 100644
index 000000000000..6b761d971220
--- /dev/null
+++ b/dev-python/python-pluginloader/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">magmax/python-pluginloader</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild b/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild
new file mode 100644
index 000000000000..6bc0182da5b4
--- /dev/null
+++ b/dev-python/python-pluginloader/python-pluginloader-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to manage python plugins/extensions"
+HOMEPAGE="https://github.com/magmax/python-pluginloader"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"