summaryrefslogtreecommitdiff
path: root/dev-python/python-openid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-openid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-openid')
-rw-r--r--dev-python/python-openid/Manifest5
-rw-r--r--dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff11
-rw-r--r--dev-python/python-openid/files/python-openid-2.2.5-tests.patch10
-rw-r--r--dev-python/python-openid/metadata.xml8
-rw-r--r--dev-python/python-openid/python-openid-2.2.5-r1.ebuild57
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/python-openid/Manifest b/dev-python/python-openid/Manifest
new file mode 100644
index 000000000000..953bb6280458
--- /dev/null
+++ b/dev-python/python-openid/Manifest
@@ -0,0 +1,5 @@
+AUX python-openid-2.0.0-gentoo-test_fetchers.diff 566 BLAKE2B 01b37542799405072abd96a87f5ac52853c894ca658f6202e2dd8ba528a5e865fa527fcba463338a6685996ad68be51c4993c38accbc961c972de0b70cbcac70 SHA512 60cb8b12312b3727263808647dd592e295ead7cebb384f92a33afe71292267e0ab95196dfdb7a01ac8847c0565c5dc9ad81f3cb95c00d6e4c9d816941b71fa44
+AUX python-openid-2.2.5-tests.patch 321 BLAKE2B fd3d0daf69dc6287191bb1a7dc61523dc13f5ce95adf8e07e7bd17f37a5f27a5984e9c85c15eb5a9f394523f2be97db67583c250a5d276b05530e95eb4dee7b1 SHA512 2d0e65763ee5fa4325e03e524ce179c367a1ba3119ce55bec458ed37bee05bb655c6a4dbc0d57ad4c20ebe22246b87da458cc688eed7d10f2cd1003f0da3f70a
+DIST python-openid-2.2.5.tar.gz 300524 BLAKE2B 9431ba3947dd2d2f7717e3f64ae91e4c014b85d67e6ce9daff5541d107c35869863de79273e6f9ad433193324d44821ccf9aaf885a6541ff7a3636a31c6ee8f5 SHA512 46ffeb07dc0e94c6e1160c824dfafd4a125746a05af1541e112bc2691bf655f75d0431ea273877899abc2956bb1f82369dea75d9b54282f33875f333f5166e7a
+EBUILD python-openid-2.2.5-r1.ebuild 1549 BLAKE2B 1c7c42551a55176cc04e7e71abee2f6fbab0a0994cc12a64a0bcfd909558299b0d9e3d6734273c4da96231ab26f4eaff3f198136e0511148998bfefba0b47766 SHA512 959c5c7335df13084a95271c3ef77b213d49e85e0feb082ecdadebde40cb935e59554a3e4e587d08fe6edd28cbffb1c0315e641c180ba2da669cf750cf1848ab
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff b/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff
new file mode 100644
index 000000000000..67587a98533a
--- /dev/null
+++ b/dev-python/python-openid/files/python-openid-2.0.0-gentoo-test_fetchers.diff
@@ -0,0 +1,11 @@
+--- openid/test/test_fetchers.py.orig 2007-06-07 15:53:38.000000000 -0700
++++ openid/test/test_fetchers.py 2007-06-07 15:53:55.000000000 -0700
+@@ -8,6 +8,8 @@
+ # XXX: make these separate test cases
+
+ def failUnlessResponseExpected(expected, actual):
++ expected.final_url = expected.final_url.replace("localhost", "127.0.0.1")
++ actual.final_url = actual.final_url.replace("localhost", "127.0.0.1")
+ assert expected.final_url == actual.final_url, (
+ "%r != %r" % (expected.final_url, actual.final_url))
+ assert expected.status == actual.status
diff --git a/dev-python/python-openid/files/python-openid-2.2.5-tests.patch b/dev-python/python-openid/files/python-openid-2.2.5-tests.patch
new file mode 100644
index 000000000000..e5d17463ac95
--- /dev/null
+++ b/dev-python/python-openid/files/python-openid-2.2.5-tests.patch
@@ -0,0 +1,10 @@
+--- admin/runtests.orig 2016-01-01 03:32:55.835000000 +0000
++++ admin/runtests 2016-01-01 03:32:59.163000000 +0000
+@@ -93,7 +93,6 @@
+ 'test_htmldiscover',
+ 'test_nonce',
+ 'test_openidyadis',
+- 'test_parsehtml',
+ 'test_urinorm',
+ 'test_yadis_discover',
+ 'trustroot',
diff --git a/dev-python/python-openid/metadata.xml b/dev-python/python-openid/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/python-openid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..20929ce8d3ab
--- /dev/null
+++ b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_REQ_USE='sqlite?'
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenID support for servers and consumers"
+HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/ https://pypi.org/project/python-openid/"
+# Downloaded from https://github.com/openid/python-openid/downloads
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+IUSE="examples mysql postgres sqlite test"
+
+RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/twill
+ dev-python/pycurl )"
+S="${WORKDIR}/openid-python-openid-b666238"
+
+python_prepare_all() {
+ local PATCHES=(
+ # Patch to fix confusion with localhost/127.0.0.1
+ "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
+ "${FILESDIR}"/"${P}-tests.patch"
+ )
+
+ # Disable broken tests from from examples/djopenid.
+ # Remove test that requires running db server.
+ sed -e "s/django_failures =.*/django_failures = 0/" \
+ -e '/storetest/d' \
+ -i admin/runtests || die "sed admin/runtests failed"
+
+ rm -v openid/test/test_parsehtml.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" admin/runtests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}