summaryrefslogtreecommitdiff
path: root/dev-python/python-novaclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-18 00:57:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-18 00:57:34 +0000
commit6330245077f9f298a785e17756a8f59a843361a5 (patch)
tree5230e465e0b66c66bfec278f434599739f6a7417 /dev-python/python-novaclient
parent0a610f61a00066203da0b0ed9ba215efbb480f4f (diff)
gentoo auto-resync : 18:11:2022 - 00:57:34
Diffstat (limited to 'dev-python/python-novaclient')
-rw-r--r--dev-python/python-novaclient/Manifest2
-rw-r--r--dev-python/python-novaclient/python-novaclient-18.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/python-novaclient/Manifest b/dev-python/python-novaclient/Manifest
index a5f30ed6d40b..4a08e93f6ded 100644
--- a/dev-python/python-novaclient/Manifest
+++ b/dev-python/python-novaclient/Manifest
@@ -1,3 +1,5 @@
DIST python-novaclient-18.1.0.tar.gz 337772 BLAKE2B 593b47e86401e83ca9b42a62bb42e531becc8ca66fb460675f3bfacea237c6d643dd38cd41abb0185714c5ee1afae10c5aea269f16672cd5131f6058e08064d6 SHA512 907acbb3b9aae0c0ad463425260b2ca4ff968efd9ac2113b36d19dfa5bced29fca0ca6f549b479b3b6089b9b6e558f3ae31617edd99e2485eafe8403893f6501
+DIST python-novaclient-18.2.0.tar.gz 337940 BLAKE2B 8b019d55089688030696a3407cbc33df09b9857fc63173a4ed4983374a35593612e43e99b0b840e239fccb42b31d97d16502d0284734789acb7b647b001b17a1 SHA512 3321449f143c253a494477296e2b4ccb20ffba877f0257b4f5e39c977946748275018c8b4094b370d2d4727325c9292a5f2c6f3f11478bd13469174de9d19390
EBUILD python-novaclient-18.1.0.ebuild 1936 BLAKE2B 1a89bbe275a97f304b1938c7d77a726577d8635148fcada5f82ade89a6fb4fbf7a3e06a5c98d92560ec107ecb7dafda8c108e882a1bee9ca142982529848d400 SHA512 73e1c7c7d8365772660e71977e7cf7bf74647c012e9fd4ffe53f6c8eb84f41aad916a8a68c0afff2be9851839599a26dd8072b1b13670ef2aa371727f47101c7
+EBUILD python-novaclient-18.2.0.ebuild 1939 BLAKE2B 8da9bc0c9a39468824acc0ae1370e9da16c4af9073e1c17e6ddaad12e9e584770a4c05b28c344e104c0ad1dac40220bdfa0e3a4d86b15c1fbf50ad61cb6dfd3d SHA512 a39ad798b009659f886a1895b2399d5bbfc01cef3af8e440abc34479a7fa7dcf881c761606b8016582c4c4954e0a82f70ff848c44ac94b214e2bdd2886638e42
MISC metadata.xml 893 BLAKE2B 42037d5052de72a81e2aac430fd14d107a0fa723c4288cd7f599bef817975ecc6b1dfc82b754ace2a50e4f9e0f5870cc6a43a3f0722d7647a38322e6cfde7eb8 SHA512 f89bf49eddaa5803ab953abc2dac189252095e529071cbd6412c15885e0a890a8e73a71295d3c3f9ebfb16bfe321316693c104d330037d112d03e04eadbf5a4d
diff --git a/dev-python/python-novaclient/python-novaclient-18.2.0.ebuild b/dev-python/python-novaclient/python-novaclient-18.2.0.ebuild
new file mode 100644
index 000000000000..1d18673c8259
--- /dev/null
+++ b/dev-python/python-novaclient/python-novaclient-18.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://opendev.org/openstack/python-novaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+ >dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+# Tests fail with dev-python/prettytable-3.4.0
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bandit[${PYTHON_USEDEP}]
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ dev-python/python-cinderclient[${PYTHON_USEDEP}]
+ dev-python/python-glanceclient[${PYTHON_USEDEP}]
+ dev-python/python-neutronclient[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/openstacksdk[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ <dev-python/prettytable-3.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -e 's/test_osprofiler/_&/' -i novaclient/tests/unit/test_shell.py || die
+ sed -e 's/novaclient\.tests\.unit\.//' -i novaclient/tests/unit/test_api_versions.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b novaclient/tests/unit
+}