summaryrefslogtreecommitdiff
path: root/dev-python/python-multipart
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-27 22:02:09 +0000
commita87296ad796f00f3bba27339f6efe11b9a384e23 (patch)
tree1a47aa193935e1eb80c6ce1c7ececdcf9d44dfb3 /dev-python/python-multipart
parent724cccb689f2076a398ede6845749926c86ea647 (diff)
gentoo auto-resync : 27:02:2023 - 22:02:09
Diffstat (limited to 'dev-python/python-multipart')
-rw-r--r--dev-python/python-multipart/Manifest2
-rw-r--r--dev-python/python-multipart/python-multipart-0.0.6.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-multipart/Manifest b/dev-python/python-multipart/Manifest
index 0d6f6fe82f4e..83516f75d4a6 100644
--- a/dev-python/python-multipart/Manifest
+++ b/dev-python/python-multipart/Manifest
@@ -1,4 +1,6 @@
AUX python-multipart-0.0.5-pyyaml.patch 987 BLAKE2B a2fe5fcc4bce4df83e86771eecbd1f81e144d3c1ff31bd61777ffaab33564904dff05f8ea741292eceaecb69208cf5b6b97e202e1cdbc9b77fee67f1235f323a SHA512 d7a4a630e38df4abc7858e892457a9d63c982d013f18554b3bec52a48c167bb14a534fccadb718600b17d8a7753b5153eed164c0fe3f8f46228847d0774dc8df
DIST python-multipart-0.0.5.gh.tar.gz 48018 BLAKE2B cfff5c1c57ada3ba3d50da71273435781d62d3907ca1b7e6180cd319f2680258b3e1e278dff760106e7ca9c116f4c5c7adf957601d6d8465bf300e6211b83773 SHA512 c2fabeb77a25119c4bbb71c3faa6de58e27ac2f0c768298eac62b519fc51e5d95fdea05c4f3846ed47205f297802982a001577a73b2feec2d9f585c784d6c3d7
+DIST python-multipart-0.0.6.gh.tar.gz 48648 BLAKE2B 4995136e6fcda8df952a6ee868238a507f3d5ea8f8454d4c4933e89b4897440f9186bd820af427f81b3240ca3610aa8300a944e4a0436291cc414f5e97daca30 SHA512 fb996725266996aefb5284b4815ecd8d0005344359f29780f0c2817125f625f3910be14d7d937e975b3ca9fb27a2a483401ab342a0c861df0e1112d447b1f083
EBUILD python-multipart-0.0.5.ebuild 734 BLAKE2B d0eccd8f6d36b9615b84e83665b0d11439704c829ea87faf390a9edd909829ec033adf6fc948331396b2925fa993485eb539f1807a240656a955ce016b312ace SHA512 e98ac4e6366b47a90d5e4cf560cba151279e2ab5083773f8e01f3c4ee6e2fc529d921e1ff70e73b3b7c9875aac0e8fdf0fb3aa6e61370b3125b72064c02187ab
+EBUILD python-multipart-0.0.6.ebuild 656 BLAKE2B bfbc56a65f26e40d039ae15bc23b9462590837cc57d0982130408bd9d95920b03ddaacef0b0769970499f56a5dab509fbe7af2239e7c227a2faeffcc4315b60d SHA512 2dd6b9f8f1d6aba423013659d3f476295eebb305984b1dfce6bf8266b790119f273f13fa54151a838511c797375c50d034bbc31c9021b7b525db467c7a37a9f3
MISC metadata.xml 409 BLAKE2B 3cdcb724c178e87f10b24cbf61160407378e90ae47789e77fd3a87e30513dac08998da154df7836f851a8cc74e6c130dfdd772bdbed2a8403da69eca8b24d4ac SHA512 6403064cacab7dc324278a5fd22f321bd1474542a66fbb2a30b30b8080f221147700f1d12073442bb8ced624b5c18fd4b3ee77cd0db087e0f758405392a92541
diff --git a/dev-python/python-multipart/python-multipart-0.0.6.ebuild b/dev-python/python-multipart/python-multipart-0.0.6.ebuild
new file mode 100644
index 000000000000..22369255e3f3
--- /dev/null
+++ b/dev-python/python-multipart/python-multipart-0.0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A streaming multipart parser for Python"
+HOMEPAGE="
+ https://github.com/andrew-d/python-multipart/
+ https://pypi.org/project/python-multipart/
+"
+SRC_URI="
+ https://github.com/andrew-d/python-multipart/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest