summaryrefslogtreecommitdiff
path: root/dev-python/python-mpv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /dev-python/python-mpv
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'dev-python/python-mpv')
-rw-r--r--dev-python/python-mpv/Manifest2
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.6.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-mpv/Manifest b/dev-python/python-mpv/Manifest
index a03575c075f1..c5925b3d2e4d 100644
--- a/dev-python/python-mpv/Manifest
+++ b/dev-python/python-mpv/Manifest
@@ -1,3 +1,5 @@
DIST python-mpv-1.0.5.gh.tar.gz 211622 BLAKE2B eeda4e61c8e2728898ddae7c2cd9e92a7cf718b22aefd8104edf361b7d7feab7655561019cbed35045cbdc4faac96e0d85c77d053bfae61e05052a981bd00342 SHA512 cefc0b38146d707a06e2b9e58951675be8d236c95e24de7665085641b24f7d7d5303130ebdb4c97f4f4c79b6de393c30656d9fc0dabf6760156d4aca8207d77c
+DIST python-mpv-1.0.6.gh.tar.gz 212503 BLAKE2B f0b63116f90b0d9e0be7d1f7e3586390d1486a89fd2eee8362f0e569b397a9d61dd597b39307559ea4206fdb98c70bbb09e07fbcbc64d60026b21522c1396053 SHA512 f5848f62f978372b04d09e89e9d04b64ff0c437a1f9f63c4ba4751bbe4a8bd0eb20e7503a3f25c7ca64ef0ab5c91db8be68473dbc29a04d78a9246ed784bcc38
EBUILD python-mpv-1.0.5.ebuild 887 BLAKE2B 3d2111f3d9fbd3d87c2914265a29cc65b1be8326ad40d8492e07ce15a2e00da71a6e1baa28f31638c331db2490972a1533c4ccee72223449eb9e140e0d534026 SHA512 ced62e50508cc866b239dfbfa54759a38b0ec10c34639178b10809c87f19b0c209da35ef451b0164e773c3dcc4bca50c7bfe66bcfa849a0f2894b8378425e7b7
+EBUILD python-mpv-1.0.6.ebuild 887 BLAKE2B b393011520c3faef4cfccfc4490c61d06b11fab8c78e8e0056b2151779018232ce54ea1d9c99b08d41b01e1901f508fcd6987d79e286877e54509bdc9fb6186b SHA512 d8a139d424371875761c3bd41da11e7160a0d14e92928c870babe2403dcf8253d9aef1905d6a78e8d1f2dbd31b39cd4d8acb4638b767f9bd142c9ec479ca693c
MISC metadata.xml 413 BLAKE2B 3e6ced6a506525bd576741fbcb1b0ce6069492dd1e90295a46b029340b833d981b351ac717e3896f4b13f3e8635065e974317298711922ab131925d98d0447a3 SHA512 9426ddc828c6b8f420c3d0241f827dd7746ca797c45182b0324b8278a24e4038a856494b420de2de572ee2643082ae271a5c21030098432736255ff2f6798db3
diff --git a/dev-python/python-mpv/python-mpv-1.0.6.ebuild b/dev-python/python-mpv/python-mpv-1.0.6.ebuild
new file mode 100644
index 000000000000..6b9246e27c40
--- /dev/null
+++ b/dev-python/python-mpv/python-mpv-1.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to the mpv media player"
+HOMEPAGE="
+ https://github.com/jaseg/python-mpv/
+ https://pypi.org/project/python-mpv/
+"
+SRC_URI="
+ https://github.com/jaseg/python-mpv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ media-video/mpv[libmpv]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # hanging tests
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_event_overflow
+ tests/test_mpv.py::TestStreams::test_custom_stream
+ )
+
+ virtx epytest
+}