summaryrefslogtreecommitdiff
path: root/dev-python/python-mpd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/python-mpd
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/python-mpd')
-rw-r--r--dev-python/python-mpd/Manifest4
-rw-r--r--dev-python/python-mpd/python-mpd-1.0.0-r1.ebuild (renamed from dev-python/python-mpd/python-mpd-1.0.0.ebuild)35
-rw-r--r--dev-python/python-mpd/python-mpd-1.1.0-r1.ebuild48
3 files changed, 71 insertions, 16 deletions
diff --git a/dev-python/python-mpd/Manifest b/dev-python/python-mpd/Manifest
index b5d099fc2648..026306518e12 100644
--- a/dev-python/python-mpd/Manifest
+++ b/dev-python/python-mpd/Manifest
@@ -1,3 +1,5 @@
DIST python-mpd-1.0.0.tar.gz 60032 BLAKE2B 9293dfc85363f83041b1d73046dabe6a3243a63de495ba630eedbda96d1b080cfb1cc635801794a91103bbd4b9145733d63ce3ad252748d01ed596cd3b0f7895 SHA512 5fab12d082be39ac4a3477ea10b5d1fa350ceac23c97fb12a46f6cd0cfa6a83999f31528d6d7f74c1ffe67f4e63dfbe8fd3debcf917a6e3705bcf84a55a458ce
-EBUILD python-mpd-1.0.0.ebuild 1007 BLAKE2B 8023ff6ff33e09d6186c4e40330996a943811181c5a5771b696610474763567e84a072adae261409b6e8be71505d492bca9a9df21893d7e58e0cddfee0e0cd6b SHA512 8f850493ae4ca365f4e6a276c85b95db9644b9005a9c86affe6386191c30a2d559078063d45474639e2b812297510fd05edb11ed35c8fe7ae05763cc3a77d272
+DIST python-mpd-1.1.0.tar.gz 61104 BLAKE2B 274a829a3fc1404a4e3beb4df3eb563c1f781325590702761d3b3b5bc42e3cd9f63809aab14bb98e4879c10ccd55bb9d7306485ec22d37538cc2e36006a3039a SHA512 65b17ae34b2c731b7d45801211e49eacfc18239d5575075be0c11ace350da19b82dd151fefc42077454a988d3deb1b489471f739ddea2d915cb3c241669dbe32
+EBUILD python-mpd-1.0.0-r1.ebuild 1020 BLAKE2B 8e0f736227abad803aeb3d94712607265454338f33f675511c650d0fb69c3b70b9a38f6dc32cceea89092257aa053645a716e1a394229283c57878164c49fd01 SHA512 35dba9b2f2a0e20fd2693e4e9988ac28c1d09b55d69732de9999778e7e87f0ae97005f466c9d0871906229688c62e4fc5056726d20f8deae3b328e71ecc068ea
+EBUILD python-mpd-1.1.0-r1.ebuild 1022 BLAKE2B 727cf4377c298a1bbd546dbdd28c1ae13f51e7784144d9ba9b219caf890068ad230a407281c59ff2da95207ea791b21658d85bdedd85f8c189d41879a1cb9475 SHA512 62669f31efb49c3b7630b61ff5fb7eb89499f8a9e014b1d59ed354cb25db5c0a40339914662397e723831622863d0d04b78ca7cba198384b82f08ba20173dff6
MISC metadata.xml 438 BLAKE2B 5429aa3c88046640fb1349404a60f1508f5d86f698ef410210507df39fd5b2d2502d8d2dafde32c8a6f02c2d01e92cca1dc37255435066dfb3a41d26850a367b SHA512 1101d7830907a54a4ccfa1a1db8e6abea802fddd3ee0827770d9e15157be6a3e9b491eebd4b80eab38074fba743fc0671686806c27accd060bf3948736a86c44
diff --git a/dev-python/python-mpd/python-mpd-1.0.0.ebuild b/dev-python/python-mpd/python-mpd-1.0.0-r1.ebuild
index bca3a1df982b..9c0299e7da29 100644
--- a/dev-python/python-mpd/python-mpd-1.0.0.ebuild
+++ b/dev-python/python-mpd/python-mpd-1.0.0-r1.ebuild
@@ -3,41 +3,46 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6..9} )
+
inherit distutils-r1
DESCRIPTION="Python MPD client library"
HOMEPAGE="https://github.com/Mic92/python-mpd2"
SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="LGPL-3"
+LICENSE="LGPL-3+"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
SLOT="0"
-IUSE="test +twisted"
+IUSE="examples +twisted"
REQUIRED_USE="test? ( twisted )"
+RDEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}"
+
BDEPEND="
test? (
- dev-python/filelock[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
)
- dev-python/setuptools[${PYTHON_USEDEP}]
"
-DEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-RESTRICT="!test? ( test )"
-DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
S="${WORKDIR}/${PN}2-${PV}"
-distutils_enable_tests setup.py
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ pytest mpd/tests.py -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
-python_prepare_all() {
- distutils-r1_python_prepare_all
- rm tox.ini || die
+ use examples && dodoc -r examples/.
}
diff --git a/dev-python/python-mpd/python-mpd-1.1.0-r1.ebuild b/dev-python/python-mpd/python-mpd-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..fd322f9116ee
--- /dev/null
+++ b/dev-python/python-mpd/python-mpd-1.1.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="https://github.com/Mic92/python-mpd2"
+SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+REQUIRED_USE="test? ( twisted )"
+
+RDEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+S="${WORKDIR}/${PN}2-${PV}"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ pytest mpd/tests.py -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}