summaryrefslogtreecommitdiff
path: root/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-mhash/python-mhash-1.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-mhash/python-mhash-1.4-r1.ebuild')
-rw-r--r--dev-python/python-mhash/python-mhash-1.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-mhash/python-mhash-1.4-r1.ebuild b/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
new file mode 100644
index 000000000000..f0e2e90e5fe8
--- /dev/null
+++ b/dev-python/python-mhash/python-mhash-1.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python interface to libmhash"
+HOMEPAGE="http://mhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="app-crypt/mhash"
+RDEPEND="${DEPEND}"
+
+python_configure_all() {
+ # Note: review this when py3 is supported
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}