summaryrefslogtreecommitdiff
path: root/dev-python/python-markdown-math
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/python-markdown-math
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/python-markdown-math')
-rw-r--r--dev-python/python-markdown-math/Manifest3
-rw-r--r--dev-python/python-markdown-math/metadata.xml20
-rw-r--r--dev-python/python-markdown-math/python-markdown-math-0.6.ebuild34
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-markdown-math/Manifest b/dev-python/python-markdown-math/Manifest
new file mode 100644
index 000000000000..bdeab8ab3d09
--- /dev/null
+++ b/dev-python/python-markdown-math/Manifest
@@ -0,0 +1,3 @@
+DIST python-markdown-math-0.6.tar.gz 6406 BLAKE2B 43172ba4b36b697f196bd569c93d56d1a3a05aaa306b1f149f3b70372e624e35fc0d3f3ea3c58c6b86e00c68408a5ebfe9fcc6562fe5065c7f8a7aa8683ee084 SHA512 af5773dc5b6d8968d811487a86fd027042d381b8b5b37683b519f03f21097bafd3d174881d8201cb6524e0975cd6868781e116cec6406fa20ffd3c6b9f9d4e87
+EBUILD python-markdown-math-0.6.ebuild 705 BLAKE2B 9554ee35ab628bad6ea6eb0bd725f443a7e4a15be24214f05f60c47accc044e0399c1e31e7c150523f7234b6e0528836bb1c954e2b99f506ae14a419ebadc141 SHA512 4255d600bd8e7878ce8d8b11da768d87304ee569d7d076ae60e3d3990cafd978ff18064f588d4da0c5d85adc21b5d772d92f54d23f41ae936c26a6b8efafb14b
+MISC metadata.xml 618 BLAKE2B 38507a41b254385cc67fc807c7bc9597c22f65bf7ccad19a128d619d1b1ee86aeef3244fa01c90ab652179a9999146f02ac5bed4f57fec308f82c03356bf88a1 SHA512 cfdc0f283f5351aa12165bf85cd9e428f8d1d4c80eda12bacacbcf11d2b195d6306bc406b64ddd7dbdc3b086c7d2fbde70a424e0169751a9b92ae48e02544802
diff --git a/dev-python/python-markdown-math/metadata.xml b/dev-python/python-markdown-math/metadata.xml
new file mode 100644
index 000000000000..d1e1d1b62523
--- /dev/null
+++ b/dev-python/python-markdown-math/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>holgersson@posteo.de</email>
+ <name>Nils Freydank</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mitya57/python-markdown-math</remote-id>
+ <remote-id type="pypi">python-markdown-math</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild b/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild
new file mode 100644
index 000000000000..2beab8d6d704
--- /dev/null
+++ b/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+
+DESCRIPTION="Math extension for Python-Markdown"
+HOMEPAGE="https://github.com/mitya57/python-markdown-math"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mitya57/python-markdown-math.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+python_test(){
+ esetup.py test
+}