summaryrefslogtreecommitdiff
path: root/dev-python/python-magic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-magic
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-magic')
-rw-r--r--dev-python/python-magic/Manifest5
-rw-r--r--dev-python/python-magic/metadata.xml13
-rw-r--r--dev-python/python-magic/python-magic-0.4.10.ebuild28
-rw-r--r--dev-python/python-magic/python-magic-0.4.15.ebuild28
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/python-magic/Manifest b/dev-python/python-magic/Manifest
new file mode 100644
index 000000000000..a4076c001dea
--- /dev/null
+++ b/dev-python/python-magic/Manifest
@@ -0,0 +1,5 @@
+DIST python-magic-0.4.10.tar.gz 3950 BLAKE2B f672b95082a68ff8fb2c4b50da0d22316456cda4b72b92d4244fdcd47c43bf599821a9577c76d99bc2a3ae578f4ff05aa76efcfcde684f27a06b90e28d58235e SHA512 8dadfd069bbca574a159dc034fca84fb110a3015ba54fa62c715006b586a5fd10373a5108a4847887bd86c6b7f2c4da90dfb7041cd5e4d51829ac1b94b8e1a03
+DIST python-magic-0.4.15.tar.gz 73194 BLAKE2B 578056caa69dc617135336d00ac7b2da45f56f48e9cf99e9fe71c4ceb6b8432927c90d1aa84516564b3ead63d501789a22f89ac681950dea0bf9735aef263625 SHA512 df028669209e02cde06f4db0481d84c316cefc191273ab3c749e88a23c92cb79a703077f601a0cc194fccbbcf62b38de8bab79290827a8505bc06e2f4aa0c2bb
+EBUILD python-magic-0.4.10.ebuild 610 BLAKE2B 091ab80438f8026e27a429a92a784455448332bae07ab2a30ca2a368ef196569ac8d75165b32caa12514685f85b6d9282cad4788ccd04499bbbc33efe72ecca6 SHA512 58275f8d490033b415fd2e95caeffbe04ea76bcf39186d33ea830e1f7c8a42bc7996286d7ce4cc8b2f18198325603b3c9f429d2ba91ee0c5041f099384177efb
+EBUILD python-magic-0.4.15.ebuild 602 BLAKE2B be54731b1d008d43dd036857d8aafb521a637641515624563a75c316594de8c2d79397d9231e39a707225afc7778f1ce19de2b08728773aa049ebadb56fa2cd9 SHA512 524f2953ec4bdc39f5f10bac892c4e9d477be7be8a14d489ea51efeeb60b47d418585b05a107127308de66e0c54d6bdd9905b4acd1e63d24677bdf1f944ecfca
+MISC metadata.xml 495 BLAKE2B 416789755f00235cc92891f85c214cd6f21751fd4c65df5d73199aac39b73245505b5fbba4b151bc03e92967859facaf8875aa4431e77af8cc9766bb2bec67af SHA512 014c7f81cb02bc8e06ff0f0cebbe15954f48715bcbb2fb34a0d9ab7291447a18359597592f026ac3d5b2082381cc9487257351dbde1bb7a2ed0ed7066563bdfa
diff --git a/dev-python/python-magic/metadata.xml b/dev-python/python-magic/metadata.xml
new file mode 100644
index 000000000000..fb7c68fe033c
--- /dev/null
+++ b/dev-python/python-magic/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thev00d00@gentoo.org</email>
+ <name>Ian Whyman</name>
+ </maintainer>
+ <longdescription>Python interface to the libmagic file type identification library.</longdescription>
+ <upstream>
+ <remote-id type="pypi">python-magic</remote-id>
+ <remote-id type="github">ahupp/python-magic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-magic/python-magic-0.4.10.ebuild b/dev-python/python-magic/python-magic-0.4.10.ebuild
new file mode 100644
index 000000000000..bf88e5cd746b
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ia64 x86"
+IUSE=""
+
+RDEPEND="sys-apps/file[-python]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# https://github.com/ahupp/python-magic/issues/97
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/python-magic/python-magic-0.4.15.ebuild b/dev-python/python-magic/python-magic-0.4.15.ebuild
new file mode 100644
index 000000000000..272c99c42619
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.15.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ia64 x86"
+IUSE=""
+
+RDEPEND="sys-apps/file[-python]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Needs MacOS python module, bug #659102
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}