summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/python-lsp-server
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.4.1.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index f23780772e98..d7216c0774bd 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,5 +1,7 @@
DIST python-lsp-server-1.3.3.tar.gz 62604 BLAKE2B 16f49013ccefc0dabcf58c6007c05828a930d0bc873805543fde79630bdc8bd020cb63d0d0ba56c181282a96c57c6084acde30dc2a8011d208040c2a93c3644b SHA512 94e9bf1e74799c395589451c02c1220bc79336e1c1cdc243e95e891f61c7977b2438d78da3db3da572022870e67305b8caca22241e0cfab23d3b546639c69aa7
DIST python-lsp-server-1.4.0.tar.gz 75443 BLAKE2B 7522ff0d5c9a0c9300f288debc4f606168f968cad80e32d612a674803046c91dc777d9ee320cf844224f6da791b6d66413c643fc48799ef5f57c19bca4f09858 SHA512 9f53e288b9bdb22575b06ec8a89022f533a323457746ef8e2cb52c84f06ac48b3408b4ebfbf96754ce68cdc9ddf1a745365d5ea21ba188a4372064fc87c1e6f4
+DIST python-lsp-server-1.4.1.tar.gz 76416 BLAKE2B 65638b876182c478434c563371b802367fb8439820ccf57e4404dc1507f3cd514ae5d738d418386607db606025fe5126a533c656ec3fede53fdcfd364a4292cf SHA512 4c9171adc88d219c80055ebbc76566583925129969467c156277b52de9b5981b74b11b9961247045ea98cd9e51e146b2d606c8351a7be5db76f6f4e0e4d7195c
EBUILD python-lsp-server-1.3.3.ebuild 3226 BLAKE2B 539d592055d3ee03e4b0a01944fa1ec3157c325220e93285d27577acb2939b7cb5ed13b94d2e0a1af798639f3210df96e248c07c1d12d81ca43fe8554e985522 SHA512 51de2e1dd4bd169a4bd70c61ce6533c1a6f55d3ab50261d80fd58d70c72e70c90b8870bf945d7da316fa1f144fb0ad5ee02a235c8f12e18501e5cddae23d7528
EBUILD python-lsp-server-1.4.0.ebuild 3225 BLAKE2B 0293ecb93bafa11e8bb2878053946d54e7f1893ab66787ca896b47cca187e6dde081ade14918506de9ae12a1d0d22e53c0c6bb104ce5a328bd80ff7efe644502 SHA512 067561897f72054192d95c5cf1cb6cebed22c12998d90c4422069c4fef9e9dc0a4a0705f8ba1eab9b8c07f6f78884b370b96a825a1c6c318760a35cb95109804
+EBUILD python-lsp-server-1.4.1.ebuild 3024 BLAKE2B d7e3a48b0034580ae677a84b446c68e05792a4bc91ed5a3bfb2c018b319bc54ecf0727541d951652161964e3f188df016dcc7f8410109dd53efc9c7220421522 SHA512 6b1d48ffd2983f94e916740899dc0aef6e9ff210772bcd33c3202ef5fe7c22b900da4c721ada2bba3790efbafbdf94b910792c25d815be0f55e06139e0e2f6c3
MISC metadata.xml 542 BLAKE2B ca71a08385d37c7f5cc562986630ae482970842054ffa944151d2e4a5d8449329b71c16c61e2a81f3d3d93f02a61ce637fe0bd0961ba3f86b7182b9728b62d5c SHA512 2d5103643838ba8aec53e7d3e924517cc3d735c724b6dfea249bcce3716aebb9f54e3264cb2cccc15dfe7d0ad4b7d052388122144fe6248d4faeef3482d197e7
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.4.1.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.4.1.ebuild
new file mode 100644
index 000000000000..f36d3cf1600b
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.4.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="all-plugins"
+
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ <dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ <dev-python/autopep8-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/flake8-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '0,/addopts/I!d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}