summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-06 11:57:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-06 11:57:11 +0100
commit2b03b0d9c5ca3890c219ebd24721133e766e9bb9 (patch)
tree5d30f335ce7ca22011789e938f980ff88db62a2c /dev-python/python-lsp-server
parentee3e7766db93c66376cf52eaac72b16fa156d223 (diff)
gentoo auto-resync : 06:10:2023 - 11:57:10
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.8.1.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index e0f37d87b88b..7e96f42e0f47 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,5 +1,7 @@
DIST python-lsp-server-1.7.4.tar.gz 97864 BLAKE2B 9832298391d72bf2f035f388694a7879d66546ead5a36837220cb3af5d8181eba198c04dd82747cba75f0478d256b001476c24b02bc679fc07cb41c7aedb0e66 SHA512 7aa96de6e51548e2854b55690698fe6c7bda60103c11ad5982df611c65569cec1ab13691727c92ec47d9ac44c34f233f872211a41041ea0969223e10e87d7e08
DIST python-lsp-server-1.8.0.tar.gz 105548 BLAKE2B aa7f714bbc7e88d68224f9a51c3c811168ade36afce02fcdf95d3ffef55f7efc964aea6fb3c26bc88c3439744928f70914c136987c89a8bd146a2f54df579ead SHA512 b8050037e313261b653f0df170762126886ceef780d7ca35651c79967270d78d9930e464ccecc71a40ceee10b0265fd262d200e1e38c50ce04490ab364bc8389
+DIST python-lsp-server-1.8.1.tar.gz 106979 BLAKE2B 3d71de40b4fff5a0e50d1e16fb1aab330c90ddc68d255f212c8ec9a1c2cc5afcbafaa9d288f938d22b824852f6ca231d48f031df3dcc7e9d97699767b3548788 SHA512 f26e836013df9ddee05f17e7629bf7abfab96aae6fc4eba9d565203b324f6e3ac3e02cbcc1bd1b9ad8a4e0628d58476797bd55564e0307a53946df7a934df11b
EBUILD python-lsp-server-1.7.4.ebuild 2926 BLAKE2B 3f7e5f4f6225f660e373754725b7a26f49a8f7e31b5726fed0e80178c11f67a52ef7f57eb0b6247c6813f0aff56ba6369e4a6c9e38d37aea1a26e3d5bfb61622 SHA512 30973ec2c9f0f0788000159ff40ab2152f1dcb37b3af9f02911ac0d4336fcf0542f6b86ffe82d9f057d63ba130f67f3b34ddada07259dd833f4b4a78d4fc0bd8
EBUILD python-lsp-server-1.8.0-r1.ebuild 3057 BLAKE2B 9ffa856cdae89cbd7edd322779bd36526351b4f4effe5fbe627d26e8ba031b7e76e59ac5186128d4c76ce364ec4bfeda551c48b7588ae92799dfb0dbd50a4e11 SHA512 add354d00079b5cd1dbca1e5119eec3679fae8df56bbbf1b9f40becf941e868cb2c2f29cd889fed8e0c5e343bb726fd583b994c644ae1ed670aa72eddfd91cbb
+EBUILD python-lsp-server-1.8.1.ebuild 3057 BLAKE2B ee4e0df9aecf8e8f4447c2092e6f742c1a7b34d6f33935f409658ee23e53256e675db444ad2ee1033c7c7d96836ded62088c58892c7d105777b97bc0a9858fd3 SHA512 b1a766df62b9ae219b55eb0e0f2578ca07daca9e0dec438686d7a2518a198e705de9a0202550efbd8ae63c7d6a6846927386bd46065ccb43cbe21c68163f22a6
MISC metadata.xml 610 BLAKE2B e111007adc2612409df72955babe0c4725fd5726449435988cf13c1142049d78089d38e54783712e2c70c74437157ffb2049bd9d63322cec084204eb5038e724 SHA512 5e1e4b43a5bfacb6a2fcae57413ebf79c6aed917b00022140d855acd773d82e56b2d73ae8270d42675a34d9f37f9ad53c8f61930c3f447d8a9e45a521a20e9bb
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.8.1.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.8.1.ebuild
new file mode 100644
index 000000000000..f94cd79aa7da
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.8.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-server/
+ https://pypi.org/project/python-lsp-server/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="all-plugins"
+
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.1.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-2.0.4[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/yapf-0.33.0[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ # unpin all the deps
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by presence of pathlib2
+ 'test/plugins/test_autoimport.py'
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}