summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-03 05:19:36 +0100
commit155cc74ccaea367efa88c8acfadcf25cb7dfe89c (patch)
tree7c071f2c978804bd5ad135f096c2c1849d338b6f /dev-python/python-lsp-server
parentd288197c01703f58dbea0ff4f42b01e7c4c6f327 (diff)
gentoo auto-resync : 03:04:2023 - 05:19:36
Diffstat (limited to 'dev-python/python-lsp-server')
-rw-r--r--dev-python/python-lsp-server/Manifest2
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 086ef01762e9..fa74014fb027 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1,4 +1,6 @@
AUX python-lsp-server-1.7.1-unpin-all-the-deps.patch 1699 BLAKE2B 0b996ff8590cb3e68007077e2ddda23f64d5ddc9ea272794aee4a9c23dc74bcd44cae65702aa4f03dfe5988c58d90d8dc21b9e249a5c7b3e80083aa0786cf330 SHA512 d46be45443f0e4282104f1e702f8ea5c9f3848f2ea3c63d7007db6876e3abd93f063aa181b2bd4916fb6ddecc6f00da0d8cafccd0eba79657b9bfce051fa735d
DIST python-lsp-server-1.7.1.tar.gz 95731 BLAKE2B 0cdcda04ef849cb0c5fa83f1f701e986e22fb1228112eaf355bfedc52cca4fcc5927352c71b74fa3903526d8a1fc80fa57ac3e6ee7bcc2609556c2398dd2bbb8 SHA512 36c90f45071f35d0aeb0a57795eb6e9fb531baf9e8b468031b0d3e9eb2d53bee439893a333c6bf5f9d5b0818ec53675a3824850abef3e866e8ebdcd4a6142c48
+DIST python-lsp-server-1.7.2.tar.gz 97050 BLAKE2B f13503d21dc8b50cfedc711bd01d47830cba7f989c14c908904f639190b883a12fabacab06d107638ec53bc84bf4f43b8aeab353793d98bfe4e8d50ddb2a671d SHA512 aaa31a72391dbf0f6b40ca954cbd2377c4105371a54036d8cbab52ee0360a2400c453d47bbccbe3bea78e3189aa4006aeb7546bd99cad3a8f0bc352a0594e885
EBUILD python-lsp-server-1.7.1.ebuild 3064 BLAKE2B 0e1d1948808a23ded46e0aea73acb4cb88acb156f50d5dc13fd6d05a6a1dcae8cba6b19e6f556abf67d87b3cbbc512eb5adba7aa859b1be67f680e7cca89b1bc SHA512 87b4c80dfb290c7cd12d0b9da6f5086e7a778e5096eb489610ff65f71b19242dbb7ff78a8c3b84bdd46958384981f639d5fb7648bffa54e99f0dc904e0b8b4d5
+EBUILD python-lsp-server-1.7.2.ebuild 2948 BLAKE2B 05cdebc6c42dbe05a5e5714aed54d4d0f56021f539507ec1cdbe512b92c732ff631782d1101702f6db16d14a4c1f47b5fc731fb9ee0f8d59e6368320d5019310 SHA512 66c18237d399fa2eb3bee29c3ed7a0a2ed35de87a6e902056d55855d1c9e120a631416329da61c921207d147c0488a43d16d2f4e96da294ec7c7a39d0ad63d93
MISC metadata.xml 610 BLAKE2B e111007adc2612409df72955babe0c4725fd5726449435988cf13c1142049d78089d38e54783712e2c70c74437157ffb2049bd9d63322cec084204eb5038e724 SHA512 5e1e4b43a5bfacb6a2fcae57413ebf79c6aed917b00022140d855acd773d82e56b2d73ae8270d42675a34d9f37f9ad53c8f61930c3f447d8a9e45a521a20e9bb
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild
new file mode 100644
index 000000000000..21e5123fbb22
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="all-plugins"
+
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # broken by presence of pathlib2
+ 'test/plugins/test_autoimport.py::test_autoimport_pathlib[completions0]'
+)
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ # unpin all the deps
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}