summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-jsonrpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/python-lsp-jsonrpc
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/python-lsp-jsonrpc')
-rw-r--r--dev-python/python-lsp-jsonrpc/Manifest4
-rw-r--r--dev-python/python-lsp-jsonrpc/files/python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch12
-rw-r--r--dev-python/python-lsp-jsonrpc/metadata.xml16
-rw-r--r--dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0.ebuild35
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/python-lsp-jsonrpc/Manifest b/dev-python/python-lsp-jsonrpc/Manifest
new file mode 100644
index 000000000000..54d1c1b4bb19
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/Manifest
@@ -0,0 +1,4 @@
+AUX python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch 342 BLAKE2B aafe30896b88531102ff79900d845a24a506ff8d0649699311e77f9ba6742f591500e2cb83a2e5aff3118a1174819b2745a8f9ca6919af8b84d379422c7e06b7 SHA512 baaa0105df9906d451a9870c7f0ca5980c6b667b7d8c4fb4f57a0fb3bfbd3f2b7502cfeea7f2abb041c2dcb344f6f5ef69822d82daed3de1ebe4564c812c7430
+DIST python-lsp-jsonrpc-1.0.0.tar.gz 10011 BLAKE2B 671490d439f10eebf2d05f221adad25be6f881f4a0f4fa975d4574937a951d4d0bc51264a9ec67d3ef5d112b6e025b551685d3e3c2b959c4a6bcef92d46c5ff3 SHA512 447835fc6c3810f486d80f85295089c021b792843bdf88d461c021b8b04407d8f7e6a99c07351a23658a5dff46eb475bc64e51bdec029787cd33330b54d4dfec
+EBUILD python-lsp-jsonrpc-1.0.0.ebuild 762 BLAKE2B 620309985c6db4abe4e06f7bce84700ca497bda184d7c7045166b69dded1e847ecab5c3e13803966c8a2adcad186af2502e4f547291425bc1cba825279cd0db7 SHA512 4b834e2273e7fa7b62b07042503779343b14f94c02d1fff98a6f04e7675767b1b425146d88dd501e3a209a2af5cf2e577e2cb138ce0ab5c3708e895d21f868e8
+MISC metadata.xml 464 BLAKE2B 604db448396e6558c6a65f823b25d5d1866b7558e72c96d4356488f002c3c27dd50c6a3a08457920a3f46805b01102e74ce6246c3c3686d686c722418e13ce14 SHA512 046b237e0b4b4cc0d19d58ebe225ded113b60704c190d5de5dc4a47cde24b7a539fe106dfc08b71fb3c96592aaffc10bc842d5f506726d65f1d024020ea14a25
diff --git a/dev-python/python-lsp-jsonrpc/files/python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch b/dev-python/python-lsp-jsonrpc/files/python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch
new file mode 100644
index 000000000000..c7b01903761b
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/files/python-lsp-jsonrpc-1.0.0-fix-test-with-ujson-3-and-up.patch
@@ -0,0 +1,12 @@
+diff --git a/test/test_streams.py b/test/test_streams.py
+index bce3ffa..f93cb8d 100644
+--- a/test/test_streams.py
++++ b/test/test_streams.py
+@@ -113,6 +113,7 @@ def test_writer_bad_message(wfile, writer):
+ hour=1,
+ minute=1,
+ second=1,
++ tzinfo=datetime.timezone.utc
+ ))
+
+ assert wfile.getvalue() in [
diff --git a/dev-python/python-lsp-jsonrpc/metadata.xml b/dev-python/python-lsp-jsonrpc/metadata.xml
new file mode 100644
index 000000000000..61471bd8fc75
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">python-lsp-jsonrpc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0.ebuild b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0.ebuild
new file mode 100644
index 000000000000..3e5baaabbc49
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.0.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON RPC 2.0 server library"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-jsonrpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/ujson-3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=( "${FILESDIR}/${P}-fix-test-with-ujson-3-and-up.patch" )
+
+python_prepare_all() {
+ # Remove pytest-cov dep
+ sed -i -e '0,/addopts/I!d' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}