summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /dev-python/python-lsp-black
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest2
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 93944a08b0e8..99f4bd44b13d 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,3 +1,5 @@
DIST python-lsp-black-1.3.0.gh.tar.gz 9781 BLAKE2B d079d7a95dff682b86df23825796d2fa6e89d1aa3e66da1452e576fd1e96a4c298da181f53840fe5fcdcbbc8a0ca55aa53cbc4885a0178b6402365ef41a239be SHA512 9e3d081ac022854626c120128949ab5e58c44f9e76ddd566e3b80a697fbc02a96f62994f43195b02f899e770768d55d223984267133eedd6f642b70560d46c09
+DIST python-lsp-black-2.0.0.gh.tar.gz 10399 BLAKE2B e38bf7ae736b3b71c1e17dd34b7e98b9bcbdbc7a12e2c1596ccdbe13b8fac8caef8a1f043aa50e1688b9159928885b8b116b709b4d2574b8ddf77172df756862 SHA512 e374ea34ac53e0d78ba198814210d9d7293e18b8fc7b22bb288621a994c8c9d492cc9c99c40cd1574b618add518671430e1e88f32e93e4c95507373932c08dc0
EBUILD python-lsp-black-1.3.0.ebuild 754 BLAKE2B 392ddb8413e88eddbd0b485749228605f9066be3814528454742ce62ac22e0e78720779e175eebdb14e2fe864788404dba0e6d4eb06452971f3b9d2705b2e1ab SHA512 d989c8e3d61e0e8d2dc77166fea91b82025634ce0c5e9c5317ae0873d116dab54820dc8915d019cf07e89bd03bddc7f9bb02845284a9055aac418da0e9f9bcc8
+EBUILD python-lsp-black-2.0.0.ebuild 882 BLAKE2B cbdeedca48eb85017a236018abce0111102e95b2df0273056a10cc8acd587a650eb54fed439a5383a229f98707e8ff371a279fe535472566001665adfc73be8b SHA512 4cf07c8af38843f259389cbc3a451c1eb88a714591afe518a5ceb5d677c0b6ef0f9c18af7aedde4182794ec5e08c6a79469b09bd8624a6e12ad30207c63b8217
MISC metadata.xml 530 BLAKE2B 385bef4e8337f4a4fbcdbd32f52dec0b0758dd0eba50c9492465caee46dbbc96402b744d5835043f50f6c89147576c96305d8fcc4cedd42254ca2a19caf9234b SHA512 121b726a498e17b6244ecad14edd8fa3fcf23297516280f10b6b4fd5c1cb784f3a6caf902764977f8abd3cd3967db6d8fbac594c773969711dd572a487cae717
diff --git a/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild
new file mode 100644
index 000000000000..6092fe46fe78
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-2.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-23.11.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ !!<dev-python/python-lsp-black-2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}