summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/python-lsp-black
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest4
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.0.0.ebuild2
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.0.1.ebuild23
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index fe805f2140f8..c6c03a520049 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,3 +1,5 @@
DIST python-lsp-black-1.0.0.gh.tar.gz 5714 BLAKE2B 8189ab4742b303f32a7963b67b40d826196d5d0420970aeeb7ff614e686be0571143a18d91f2964dc3fd48b71d3d5fb77f76f0877df0c462eef5d2c996200a44 SHA512 46377a4d1bdd40e72a6174468838ed06b26a403029a6911c52dd325581b3423bf9b2c4decc6c931cb177ca9ad481135531e176b0afa602236acbb3dd18f490be
-EBUILD python-lsp-black-1.0.0.ebuild 598 BLAKE2B 39bc85212ac3d61159d488f857aab66368ee257f7713ded17349ed03232fbc473c39ab7db67d19cc5dc35d37a241cdc2feeb3d4876216d2aca2495be09228e24 SHA512 5818a5ca0b1b62e844c98e3e555a583213f4221760f47582d0e7894db7858434b435d46981b020d3557cf944f8e1d4afddab3b2f8b6ce201bd052f8c7ba2d784
+DIST python-lsp-black-1.0.1.gh.tar.gz 7013 BLAKE2B 596ef3f468524269fb2765ad7ba0f8305c9e67ec4cf826dbe68ea20058f1fc595c004b34c5228c14a70b6a489e29f370fef93cd7a9ef48d24ace3464ec7cd011 SHA512 43699438bf64b9cfb5dfa97b30385870a06d15be90d5a023c5282f1b969188e8536961c2a2ee6f1016d4b8188e4df6a81d6127dd628242bbcd3fbcc640504a24
+EBUILD python-lsp-black-1.0.0.ebuild 599 BLAKE2B 5dd97910726a6cf924edae6f8c1e7cb6928052763412f5cb1fde008af2ae1d2b17c2849d8f10fcb862b6c09d0f5a1ee054c39d810f87a834b6b95de450197ced SHA512 4aae69e63d6c0ca63c99fc07db2e0a666c95d8f7fcc53c22d0f5b9d0b25a8f456555e87c058cd8f3552594c858625cec35fee8f862277de5834324cc967d2ee1
+EBUILD python-lsp-black-1.0.1.ebuild 600 BLAKE2B 57b90d9ed66d0d43077796e2e8b603c552107301b0a09d4a7d8742822e125be43a99da7687db2986bdf95229c7dfbf13387ef6404038c63914b422ce5ef47113 SHA512 63a913690242ad734f7a59402da532ed408cc945571d32a7ad5d8112ffc764bae4407901c0b6d55ac5e2268e272c26b4abe3746bb4c5d8c16bbe9c51cf1aab6f
MISC metadata.xml 429 BLAKE2B fcfbbc17f713e9f33164eac55cde53fb505d550a9049bf843809cb688f038912770764332e8eed56ef39972ff82e39e1a27a2d8248d887950857fb790e6a7bc1 SHA512 6a1438c96853dd9fe11eceaddc7e350311db01a95f17fa05b3f2cf651ae778b5361b9612423c2d124bf4dfdaccea836538a3aade91dc58efd4feb81dba23ada7
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.0.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.0.0.ebuild
index b60185ad4b9b..8a460548a55d 100644
--- a/dev-python/python-lsp-black/python-lsp-black-1.0.0.ebuild
+++ b/dev-python/python-lsp-black/python-lsp-black-1.0.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.0.1.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.0.1.ebuild
new file mode 100644
index 000000000000..bb392d7fbfbb
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-black
+ https://pypi.org/project/python-lsp-black/"
+SRC_URI="https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/python-lsp-server[${PYTHON_USEDEP}]
+ >=dev-python/black-19[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest