summaryrefslogtreecommitdiff
path: root/dev-python/python-lsp-black
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-22 08:56:17 +0100
commit07a79a268edfbac4dba8c66eff20cbdc2aac0f6a (patch)
treebc6688a3cc8c802970aa5e29936310ae9b76ccda /dev-python/python-lsp-black
parent470949042cc90856adb62f2671e04e3165fc8063 (diff)
gentoo auto-resync : 22:05:2023 - 08:56:17
Diffstat (limited to 'dev-python/python-lsp-black')
-rw-r--r--dev-python/python-lsp-black/Manifest2
-rw-r--r--dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-lsp-black/Manifest b/dev-python/python-lsp-black/Manifest
index 3eceb6e9708e..da6d2dac00dc 100644
--- a/dev-python/python-lsp-black/Manifest
+++ b/dev-python/python-lsp-black/Manifest
@@ -1,4 +1,6 @@
AUX python-lsp-black-1.2.1-tomli.patch 2955 BLAKE2B 9627be0dcae6a723242e22831384caa772082842a1ae4758534ad40e99402a2f9adc8677b547a2ba899e5763e0d9785c51afced6aafc620d0e0927f6bf719997 SHA512 3fcea10adfd6f25abcf5dda95c4d2ed4e86666d06522baa014fe805dbc6c06a825af1491a931610eabdd5e907f4d34b94513aa3caa4ba43cc584859ae5a76035
DIST python-lsp-black-1.2.1.gh.tar.gz 9355 BLAKE2B f9c70ff07d9dfa31e3af919143deb8a49f43269469e8c64525f514624f4db67636da8254dae5274685ba2d883c8ddfd6dd9cb99981a337d7837d4007f15af11c SHA512 289b8f3642ed806409671d25e32997fb473720d0abd642c58c07d8c894831fa00f56dbc39e7d0fc8d98cad7de9f95ebdb6a0f637b8b4bbcc2a0716690feb647e
+DIST python-lsp-black-1.3.0.gh.tar.gz 9781 BLAKE2B d079d7a95dff682b86df23825796d2fa6e89d1aa3e66da1452e576fd1e96a4c298da181f53840fe5fcdcbbc8a0ca55aa53cbc4885a0178b6402365ef41a239be SHA512 9e3d081ac022854626c120128949ab5e58c44f9e76ddd566e3b80a697fbc02a96f62994f43195b02f899e770768d55d223984267133eedd6f642b70560d46c09
EBUILD python-lsp-black-1.2.1-r1.ebuild 798 BLAKE2B af637a16edf52a16c791db28c3eeb853f9e4848dd13dbcb925d51ab92bfe707da00e0797f09a5cb9a96984e88236195c62e18f336b58085acddf3402c8f7bcb4 SHA512 f62b8f0963533539ca964d5bd823c094131d6c544bd12a703e58e3f3fb8de870c2574f773f0b6cfa2578be7687fe0e72d658b8c4909b007c7f431622aa25b844
+EBUILD python-lsp-black-1.3.0.ebuild 751 BLAKE2B e937e4c903f46a036b4ee337df2a1ae1f25cddec19dc3d0152d08971581435457bc928aee9a775b8c55c64316c7b4aa06ee9829e79410929568600b76e0d315b SHA512 82dfca6b7a88c65aa1a9ff2852dcee104ebb422cf41af0d7699265f8a4548a4809a6d4726724818ee3ba0586fa83f139c89716c2cecb87b51eb9d23e181dc1ea
MISC metadata.xml 530 BLAKE2B 385bef4e8337f4a4fbcdbd32f52dec0b0758dd0eba50c9492465caee46dbbc96402b744d5835043f50f6c89147576c96305d8fcc4cedd42254ca2a19caf9234b SHA512 121b726a498e17b6244ecad14edd8fa3fcf23297516280f10b6b4fd5c1cb784f3a6caf902764977f8abd3cd3967db6d8fbac594c773969711dd572a487cae717
diff --git a/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild b/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild
new file mode 100644
index 000000000000..9274bf63b458
--- /dev/null
+++ b/dev-python/python-lsp-black/python-lsp-black-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python LSP Server"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-black/
+ https://pypi.org/project/python-lsp-black/
+"
+SRC_URI="
+ https://github.com/python-lsp/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-lsp-server-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/black-22.3.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests pytest