summaryrefslogtreecommitdiff
path: root/dev-python/python-linux-procfs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/python-linux-procfs
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/python-linux-procfs')
-rw-r--r--dev-python/python-linux-procfs/Manifest2
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-linux-procfs/Manifest b/dev-python/python-linux-procfs/Manifest
index dfedc2635b0d..85af58a16e76 100644
--- a/dev-python/python-linux-procfs/Manifest
+++ b/dev-python/python-linux-procfs/Manifest
@@ -1,3 +1,5 @@
DIST python-linux-procfs-0.6.3.tar.xz 18808 BLAKE2B 02fdc0349dd456819f67f82d6836a44e3285e16d9654dd52b58ac7d86e48bc559feda18f105db7911ac5f670fd0e6cfd5c6cc69a958a3e8494813ff244f8b06f SHA512 18e42bf12456893740c5ec950ffcca86945b1ff202a6ea3ae6ac800145771a39b4ab7e8bbb440210d48d0fe9de646e334095afd0b20060e2e28ab3fa844f6140
+DIST python-linux-procfs-0.7.1.tar.xz 19104 BLAKE2B e6e495ecce77c1ea4c1580c2534e87f769a0057702648ee75bf89f5cbaa944012ba17e69c231977889b9b18d8e9b8d67261361b499ef8a567bed978a207d61ec SHA512 532613cd0feab1317131a3ec30e0730ed48415de333f1430573b7bf0eb5525222dc92db38dab6ff76c27ff10ac0a381975c329441b9ca6011e79bd637482056d
EBUILD python-linux-procfs-0.6.3.ebuild 591 BLAKE2B cc0d2c346d4a09e51f4feda85fb85e4e77b87104cee140c150732123cd7cffa4d9918eddbe159968cb8993376ebe7ca0d4288581ae577a16006f0b8a6ca5383c SHA512 63f73d53137ff5c4e175868bb9f535cf1a6168a19d4d394f2004a5c7bf8cc4c34cd9b5fe8f5a36aa0779d37f4fc4d9cc53d16dc8be3ea1b7637888d29d3a63af
+EBUILD python-linux-procfs-0.7.1.ebuild 715 BLAKE2B 3f3dcb13ef4a02f6b3ccabe5027917e28b1b06b2f81d70cdc72509b2edc613ec25c372fd4988bfab46ea2374cd243934a72c3c41f083b60e1a5671707f9152e9 SHA512 a1c55ca2b7dcec0b9d4eccb9b043b146b64b3cadd52bcee952983d6a81fab0f94f24552166ffe2b5ca11b7bf9f1c410c534e5bcad569d1d938ccade75387b969
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
new file mode 100644
index 000000000000..89622b4136e5
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
+ https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/
+"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
+}