summaryrefslogtreecommitdiff
path: root/dev-python/python-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 10:17:50 +0100
commit399fa07bfac673a8846466b16c76549e329b55b8 (patch)
tree29af17ef91f1bd986b8e615a96b61db7fad5df14 /dev-python/python-ldap
parent388a0747e5972613060d5ca13955b5cd7132533d (diff)
gentoo auto-resync : 20:05:2023 - 10:17:50
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest1
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild88
2 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index 4f76e812d1c9..4ddf708363ac 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,4 +1,3 @@
DIST python-ldap-3.4.3.gh.tar.gz 378215 BLAKE2B d5c165e668ed8bf1415e06e28e306bb757dea71ee7cc1ad380c35a5d911767fd08e249577aef0e5e888c1e9129072f93f499560e8b70e6848fbad4d7f9bb95a6 SHA512 a52403b7d9fc4d114b995640ff34f5aefd313d36cea5ff6de73ea9f46036694ebd43cd9d11382daf3be9da887f62c6675b49d684c05a7d5f0c93d446b16d1981
EBUILD python-ldap-3.4.3.ebuild 1720 BLAKE2B 49e2da601de4b8215889a303447f639c1fadd1c1682d88319f5e17b4f8ac8cabfa2ac23851b27fb7d5d23891959bc9d7322b52b853b38c0b9423ec33dd74a032 SHA512 cafbc3566df40bb7a76fd32169da2456d3ace4367937425edbd008bbcf3d2c5103f8eaad2a5471497b70673039cc12e4429af0aed0e5eb9f14bdba972dd26540
-EBUILD python-ldap-9999.ebuild 2000 BLAKE2B b3afc013a6bf60000d1dd28b01195a9c5f16354cadda0ca160b7b38fa26234330f9e615a708a766e4ce6444d36a97696efb9cbdb2944ce5c7d5bea991b59baab SHA512 f02f3e1b7a342dd57e7889c17f72349c3c6a44c4d1fbe762bfef25999a32bc5038e10d9e12ef46d987c45e257008bec25ca2b7886c04ab3ead30a05a5daf8222
MISC metadata.xml 449 BLAKE2B 14ffa18ca09eb663d3ef4ff5bd0ebc8511fa408a4e96c93885ba2beaccdf3bb82a9733a01149e088c8b66d6cb938f94fc3940c0c0cca5685599191e772443cb6 SHA512 2f5c014e55f838b84abf6ba630b000620a01e2fca6d1f1bd1b30db309f820df50c2ef7feddc17c69ee0188c3cbc91a388933b4bccfc8d2ea0cb18c6dae85cda6
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
deleted file mode 100644
index 0e12e7bd1eff..000000000000
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="Various LDAP-related Python modules"
-HOMEPAGE="https://www.python-ldap.org/en/latest/
- https://pypi.org/project/python-ldap/
- https://github.com/python-ldap/python-ldap"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/python-ldap/python-ldap.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
-fi
-
-LICENSE="MIT PSF-2"
-SLOT="0"
-IUSE="examples sasl ssl"
-
-RDEPEND="
- >=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
- net-nds/openldap:=[sasl?,ssl?]
-"
-# We do not link against cyrus-sasl but we use some
-# of its headers during the build.
-DEPEND="
- net-nds/openldap:=[sasl?,ssl?]
- sasl? ( >=dev-libs/cyrus-sasl-2.1 )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx Doc
-
-python_prepare_all() {
- # The live ebuild won't compile if setuptools_scm < 1.16.2 is installed
- # https://github.com/pypa/setuptools_scm/issues/228
- if [[ ${PV} == *9999* ]]; then
- rm -r .git || die
- fi
-
- if ! use sasl; then
- sed -i 's/HAVE_SASL//g' setup.cfg || die
- fi
- if ! use ssl; then
- sed -i 's/HAVE_TLS//g' setup.cfg || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # Run all tests which don't require slapd
- local EPYTEST_IGNORE=(
- t_bind.py
- t_cext.py
- t_edit.py
- t_ldapobject.py
- t_ldap_options.py
- t_ldap_sasl.py
- t_ldap_schema_subentry.py
- t_ldap_syncrepl.py
- t_slapdobject.py
- )
- pushd Tests >/dev/null || die
- epytest
- popd > /dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
- python_optimize
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r Demo/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}