summaryrefslogtreecommitdiff
path: root/dev-python/python-ldap/python-ldap-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-30 21:33:31 +0100
commit2f8db31405fac68eea6f7257d58529243815033b (patch)
tree54259cc8988a98a10586fc0496b1f3501cd1e2a1 /dev-python/python-ldap/python-ldap-9999.ebuild
parenta4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (diff)
gentoo resync : 30.04.2018
Diffstat (limited to 'dev-python/python-ldap/python-ldap-9999.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-9999.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/dev-python/python-ldap/python-ldap-9999.ebuild b/dev-python/python-ldap/python-ldap-9999.ebuild
index 468171efb88c..ee6ebf08e0ea 100644
--- a/dev-python/python-ldap/python-ldap-9999.ebuild
+++ b/dev-python/python-ldap/python-ldap-9999.ebuild
@@ -1,33 +1,39 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-# pypy: bug #458558 (wrong linker options due to not respecting CC)
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 pypy )
-inherit distutils-r1 git-2 multilib
+inherit distutils-r1
DESCRIPTION="Various LDAP-related Python modules"
HOMEPAGE="https://www.python-ldap.org/en/latest/
https://pypi.org/project/python-ldap/"
-EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/xmw/python-ldap.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+fi
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS=""
IUSE="doc examples sasl ssl"
# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
# python team: Please do not remove python-ldap-2.3.9 from the tree.
RDEPEND=">=net-nds/openldap-2.4
dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}] )"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ )
+"
RDEPEND+=" !dev-python/pyldap"
python_prepare_all() {