summaryrefslogtreecommitdiff
path: root/dev-python/python-ldap/python-ldap-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-11 07:02:28 +0100
commit068424b26532f3551a81421a9be67ed206e5c11a (patch)
tree583b8d979899a463a4ef5b26d3d49e85df987623 /dev-python/python-ldap/python-ldap-3.3.1.ebuild
parentd162ba1860a88062f4cd61f8b52fc303ba0b2991 (diff)
gentoo resync : 11.08.2021
Diffstat (limited to 'dev-python/python-ldap/python-ldap-3.3.1.ebuild')
-rw-r--r--dev-python/python-ldap/python-ldap-3.3.1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/python-ldap/python-ldap-3.3.1.ebuild b/dev-python/python-ldap/python-ldap-3.3.1.ebuild
index ba9b8d5ece63..bd5fd8bb1e72 100644
--- a/dev-python/python-ldap/python-ldap-3.3.1.ebuild
+++ b/dev-python/python-ldap/python-ldap-3.3.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -25,7 +25,6 @@ IUSE="examples sasl ssl"
# We do not need OpenSSL, it is never directly used:
# https://github.com/python-ldap/python-ldap/issues/224
RDEPEND="
- !dev-python/pyldap
>=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
>net-nds/openldap-2.4.11:=[sasl?,ssl?]
@@ -71,8 +70,7 @@ python_test() {
t_slapdobject.py
)
pushd Tests >/dev/null || die
- pytest -vv ${ignored_tests[@]/#/--ignore } \
- || die "tests failed with ${EPYTHON}"
+ epytest ${ignored_tests[@]/#/--ignore }
popd > /dev/null || die
}