summaryrefslogtreecommitdiff
path: root/dev-python/python-jwt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/python-jwt
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/python-jwt')
-rw-r--r--dev-python/python-jwt/Manifest3
-rw-r--r--dev-python/python-jwt/metadata.xml17
-rw-r--r--dev-python/python-jwt/python-jwt-1.2.0.ebuild30
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-jwt/Manifest b/dev-python/python-jwt/Manifest
new file mode 100644
index 000000000000..78497e5528ed
--- /dev/null
+++ b/dev-python/python-jwt/Manifest
@@ -0,0 +1,3 @@
+DIST python-jwt-1.2.0.tar.gz 22578 BLAKE2B e8ed53c87f55f829e134955d03efd4c4a8e34e1eaa03f20a644db71d7b79d21564344a856206ad72aa5e0fa8cb8fa799d710a9669850c50c7aa588bfa59d7962 SHA512 c663e3fbb6476ae60b485e497f898aed2db84aa10c677ef2fc46160b355ea51af31ed259117fe20937809068e6c586e4f48b4e217722a47231f19be59f25295c
+EBUILD python-jwt-1.2.0.ebuild 772 BLAKE2B 684362915c56c162280399ab5459f920b5dcbc8a6330806a39c69ae83d718592cc52bba26934dc6a1d0d2e8dc5d0662466fab93f4bd20ecf8634152e68acca8d SHA512 fbe2d4983a23ce79a846c7b3ffef0aa8be2d972e250b9b5991ab73b9b32f7b8010f3cb1e458f5ca4f5ad50dc81ba41f0e9c157bb85f3bd74a1344b12938799b9
+MISC metadata.xml 508 BLAKE2B d1d762e5fb0ec41936b78c51f9ff539479968a2e135f42255e48da380e7fc0c35d1fe47d5b4ed7029131983d703cda31d751eee317c9a943dd2cb269dcfbaf46 SHA512 782efa147b5a52ef92d0a6c1d61ae2352f7f5008dc04dda5db5faaa8e112062daf546444799b4101fdfa201819ba08a46ef79ce7c5494003d27df6e95e3c538e
diff --git a/dev-python/python-jwt/metadata.xml b/dev-python/python-jwt/metadata.xml
new file mode 100644
index 000000000000..fb6d10e660c9
--- /dev/null
+++ b/dev-python/python-jwt/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">GehirnInc/python-jwt</remote-id>
+ <remote-id type="pypi">jwt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-jwt/python-jwt-1.2.0.ebuild b/dev-python/python-jwt/python-jwt-1.2.0.ebuild
new file mode 100644
index 000000000000..e10f83af9f6e
--- /dev/null
+++ b/dev-python/python-jwt/python-jwt-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_8 python3_9 )
+inherit distutils-r1
+
+DESCRIPTION="JSON Web Token library for python 3"
+HOMEPAGE="https://github.com/GehirnInc/python-jwt"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hvac/hvac.git"
+else
+ SRC_URI="https://github.com/GehirnInc/python-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="test? ( dev-python/freezegun[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e 's/^addopts =.*/addopts = jwt/' setup.cfg || die
+ distutils-r1_python_prepare_all
+}