summaryrefslogtreecommitdiff
path: root/dev-python/python-iptables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/python-iptables
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/Manifest3
-rw-r--r--dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch21
-rw-r--r--dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild (renamed from dev-python/python-iptables/python-iptables-1.0.0.ebuild)4
3 files changed, 27 insertions, 1 deletions
diff --git a/dev-python/python-iptables/Manifest b/dev-python/python-iptables/Manifest
index 0291640b0f9f..25aba0f1d6d9 100644
--- a/dev-python/python-iptables/Manifest
+++ b/dev-python/python-iptables/Manifest
@@ -1,3 +1,4 @@
+AUX python-iptables-1.0.0-ldconfig-fix.patch 652 BLAKE2B e672670d6e6cd804821ef2e68f968edaf372270ea31979da2e1b69c5e9233e8ba3fc5a8870c545fae7eb77b1defee0ba3fb18d1e25fe6504112a84442aa5fa8a SHA512 23c94efd33542ce7c1b87084a35c76431e85de6138ce9b6e2365def28d493814682e85dbf869bdb4f7d2b75c1def3a1c6af9fd5546f2c91ffe442d50c43c61f1
DIST python-iptables-1.0.0.tar.gz 52245 BLAKE2B f61cf655440a40c96e49452caa1070046e539313ce709c629cb93c11ac66d51dad5fb11c183a8babbba5766b8bea27d0ab604d7aec104775371791cedc2262f6 SHA512 417ebec4391c6967f3b1cfa56d79dc1c6d053570d71bb29713ed327ee1fd52e0be9c3b9a62a1ae666644bbb472e5174402584cd5ddfb0b24c11e1d30773bcea5
-EBUILD python-iptables-1.0.0.ebuild 714 BLAKE2B 34ef04307c585ef473a9371556d37c31c03e89e638d009073306632994b4a4d63f711c342438832719a2f85546aaf60f9781ec990f816479217c191f664eed64 SHA512 b36c480bc7d0a08aa971ea47b6e676298c8d1b5ab918bfb1c619b154bb6bebd87a0f819f1b97bb9334e05a6665c1c2ca6be10d5a6701932c09f4a3937840d3ca
+EBUILD python-iptables-1.0.0-r1.ebuild 783 BLAKE2B f8436968687cbcdb4faa7df749221eaf632250361bca3421f580dcdc68fcb6be12ad564eaa5debe418481f2980038d0b457a593ac2b995f70a92a3afe74cfc30 SHA512 b4864da485bbcf0d63bb8094ad87f0fd1dc188dd777c04446aa5dc5b5bef8cc130c35f160a41deffb3973d1a83ecccc71c2fee5e13bc2d39071f064af634f8da
MISC metadata.xml 1340 BLAKE2B d7f6bd56d29a11e19dc402343c03007866bfa0e33415317d866bdc9e7b76bd2cc35238270db24299cb31986166044f5bbc84d90efa37e9fad36fe8b16ffc3e03 SHA512 90c875cee0c4ea9e2f34d509152cdd4d83a41010b8a858515fa3bc766bb0ba11e047957f4c005fdaf2e49b088df78cb3b4414a5ecfdb1b6ded550eb6c9dd01d9
diff --git a/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch b/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch
new file mode 100644
index 000000000000..14fe9eae38da
--- /dev/null
+++ b/dev-python/python-iptables/files/python-iptables-1.0.0-ldconfig-fix.patch
@@ -0,0 +1,21 @@
+diff --git a/iptc/xtables.py b/iptc/xtables.py
+index cf21029..8f62164 100644
+--- a/iptc/xtables.py
++++ b/iptc/xtables.py
+@@ -4,6 +4,7 @@ import ctypes as ct
+ import os
+ import sys
+ import weakref
++import pathlib
+
+ from . import version
+ from .util import find_library, find_libc
+@@ -805,7 +806,7 @@ _lib_xtables, xtables_version = find_library(_searchlib)
+ _xtables_libdir = os.getenv("XTABLES_LIBDIR")
+ if _xtables_libdir is None:
+ import re
+- ldconfig_path_regex = re.compile('^(/.*):$')
++ ldconfig_path_regex = re.compile(r'^(/.*): \(.*$')
+ import subprocess
+ ldconfig = subprocess.Popen(
+ ('/sbin/ldconfig', '-N', '-v'),
diff --git a/dev-python/python-iptables/python-iptables-1.0.0.ebuild b/dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild
index 53037c8775b5..b69547d73fee 100644
--- a/dev-python/python-iptables/python-iptables-1.0.0.ebuild
+++ b/dev-python/python-iptables/python-iptables-1.0.0-r1.ebuild
@@ -18,6 +18,10 @@ RDEPEND="net-firewall/iptables"
# tests manipulate live iptables rules, so disable them by default
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}/python-iptables-1.0.0-ldconfig-fix.patch"
+)
+
distutils_enable_sphinx doc
distutils_enable_tests setup.py