summaryrefslogtreecommitdiff
path: root/dev-python/python-iptables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/python-iptables
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/Manifest2
-rw-r--r--dev-python/python-iptables/python-iptables-1.0.0.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-iptables/Manifest b/dev-python/python-iptables/Manifest
index 5e19227bda28..5286b74487f4 100644
--- a/dev-python/python-iptables/Manifest
+++ b/dev-python/python-iptables/Manifest
@@ -1,3 +1,5 @@
DIST python-iptables-0.13.0.tar.gz 83456 BLAKE2B 9c8da40437d408c6bb49e700b8d1663e7fdb0a1001b15409cf4c8b9edf612f75eb546207bc86d0535f8fb3744e42244f3e067dff80037c5a3eadc028ec8024f3 SHA512 1693924b8ee79b3b0929b57e86908282d53d28044b063d7bd169a6e9c1b45b5b6b4a79e54d024beedbfd6e42f88417eb2d0312bf90895702a3b8bfe2c2eb22b2
+DIST python-iptables-1.0.0.tar.gz 52245 BLAKE2B f61cf655440a40c96e49452caa1070046e539313ce709c629cb93c11ac66d51dad5fb11c183a8babbba5766b8bea27d0ab604d7aec104775371791cedc2262f6 SHA512 417ebec4391c6967f3b1cfa56d79dc1c6d053570d71bb29713ed327ee1fd52e0be9c3b9a62a1ae666644bbb472e5174402584cd5ddfb0b24c11e1d30773bcea5
EBUILD python-iptables-0.13.0.ebuild 919 BLAKE2B 88a236355660ed1e9ea86584735703a399b623dc43c62a6087efd1412dedf586f325b2e3aa1d525998cad9cbd36bc8f4b1d1b26f0741a60427818c3d0ca52d08 SHA512 33021e2b05d79e023059a033bb296c274ea7c300d5430b450b0473843f886dddc6042ad39454ef0b7b477fc12b005e74795fdc2d603336b627115a85d5168818
+EBUILD python-iptables-1.0.0.ebuild 714 BLAKE2B 34ef04307c585ef473a9371556d37c31c03e89e638d009073306632994b4a4d63f711c342438832719a2f85546aaf60f9781ec990f816479217c191f664eed64 SHA512 b36c480bc7d0a08aa971ea47b6e676298c8d1b5ab918bfb1c619b154bb6bebd87a0f819f1b97bb9334e05a6665c1c2ca6be10d5a6701932c09f4a3937840d3ca
MISC metadata.xml 1340 BLAKE2B d7f6bd56d29a11e19dc402343c03007866bfa0e33415317d866bdc9e7b76bd2cc35238270db24299cb31986166044f5bbc84d90efa37e9fad36fe8b16ffc3e03 SHA512 90c875cee0c4ea9e2f34d509152cdd4d83a41010b8a858515fa3bc766bb0ba11e047957f4c005fdaf2e49b088df78cb3b4414a5ecfdb1b6ded550eb6c9dd01d9
diff --git a/dev-python/python-iptables/python-iptables-1.0.0.ebuild b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
new file mode 100644
index 000000000000..53037c8775b5
--- /dev/null
+++ b/dev-python/python-iptables/python-iptables-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for iptables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+# tests manipulate live iptables rules, so disable them by default
+RESTRICT="test"
+
+distutils_enable_sphinx doc
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}