summaryrefslogtreecommitdiff
path: root/dev-python/python-iptables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/python-iptables
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-iptables')
-rw-r--r--dev-python/python-iptables/Manifest3
-rw-r--r--dev-python/python-iptables/metadata.xml25
-rw-r--r--dev-python/python-iptables/python-iptables-0.12.0.ebuild37
3 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/python-iptables/Manifest b/dev-python/python-iptables/Manifest
deleted file mode 100644
index 8307a6d7a55e..000000000000
--- a/dev-python/python-iptables/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST python-iptables-0.12.0.tar.gz 40831 BLAKE2B ea53605a5dd581cad7e05059c1534376a53b3b3da89b8c172cbb38ae7482ca3972fdf786badf3328960847c12c96ce32278657c32c857a1682650621a3add47a SHA512 bf79288fac53542e523c8ed0e4e0711792cf524100e39f57f10d3581d1b958712875a765f690b3d5ec6e28af9de48d2f3dd0a787c7037ebfc6f8bf87b5e321b2
-EBUILD python-iptables-0.12.0.ebuild 930 BLAKE2B fd4701dfbab5e7348088e3a686c02bcfac8fb809d9270568a839fc0dc6147665345433799352e2ec8b48bb686c6293241c520433f3c4977116c9adbc9276ff16 SHA512 0658bda1fa29b4f61af9ea99c4624d8afd2a9cd6c20767b90bc897628a74110a3d366e92c2582d8f4fa7909a59294ff4ffbc25bf92baee11ba0a37992914926c
-MISC metadata.xml 1340 BLAKE2B d7f6bd56d29a11e19dc402343c03007866bfa0e33415317d866bdc9e7b76bd2cc35238270db24299cb31986166044f5bbc84d90efa37e9fad36fe8b16ffc3e03 SHA512 90c875cee0c4ea9e2f34d509152cdd4d83a41010b8a858515fa3bc766bb0ba11e047957f4c005fdaf2e49b088df78cb3b4414a5ecfdb1b6ded550eb6c9dd01d9
diff --git a/dev-python/python-iptables/metadata.xml b/dev-python/python-iptables/metadata.xml
deleted file mode 100644
index 65690818b3ab..000000000000
--- a/dev-python/python-iptables/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- Python Bindings for IPtables: Iptables is the tool that is used to manage netfilter,
- the standard packet filtering and manipulation framework under Linux. As the iptables
- manpage puts it: Iptables is used to set up, maintain, and inspect the tables of IPv4
- packet filter rules in the Linux kernel. Several different tables may be defined.
- Each table contains a number of built-in chains and may also contain user-defined
- chains. Each chain is a list of rules which can match a set of packets. Each rule
- specifies what to do with a packet that matches. This is called a target, which may be
- a jump to a user-defined chain in the same table. Python-iptables provides python
- bindings to iptables under Linux. Interoperability with iptables is achieved via
- using the iptables C libraries (libiptc, libxtables, and the iptables extensions), not
- calling the iptables binary and parsing its output.
- </longdescription>
- <upstream>
- <remote-id type="pypi">python-iptables</remote-id>
- <remote-id type="github">ldx/python-iptables</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-iptables/python-iptables-0.12.0.ebuild b/dev-python/python-iptables/python-iptables-0.12.0.ebuild
deleted file mode 100644
index 360518b2f5ca..000000000000
--- a/dev-python/python-iptables/python-iptables-0.12.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for iptables"
-HOMEPAGE="https://github.com/ldx/python-iptables"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="net-firewall/iptables"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# tests manipulate live iptables rules, so disable them by default
-
-python_prepare_all() {
- # Prevent un-needed d'loading during doc build
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}