summaryrefslogtreecommitdiff
path: root/dev-python/python-gnutls
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-gnutls
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-gnutls')
-rw-r--r--dev-python/python-gnutls/Manifest3
-rw-r--r--dev-python/python-gnutls/metadata.xml31
-rw-r--r--dev-python/python-gnutls/python-gnutls-3.1.1.ebuild20
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/python-gnutls/Manifest b/dev-python/python-gnutls/Manifest
new file mode 100644
index 000000000000..ece77cda368a
--- /dev/null
+++ b/dev-python/python-gnutls/Manifest
@@ -0,0 +1,3 @@
+DIST python-gnutls-3.1.1.tar.gz 40593 BLAKE2B 719fd47133e7eb04d682e9757cb810086a79db7cab10fb5bbe206a9b6af1cccd1a94756c7c162ac09e0cf8a487bccd13923c38fa8b89398090d5bd21bc0116e2 SHA512 471127d548cc4f44fb7b2da4d6db23cff66378b45eefde2ea4950ee08d849b1a5aed86245cd2a8a5f46fd53c652d433d23b658184a00e8e5514da3f518a080ab
+EBUILD python-gnutls-3.1.1.ebuild 425 BLAKE2B 9abe380965f8032195e24bf89fa9c166b277db18f58a9926c71f7d86d48d8474e52416edc3fecd9127355107d8f306a2441a51c6c7224ea112d83489c63209d7 SHA512 1de48e66fd71b80eadee204031aadb58985b421ed45d8403226b2a35d37255959ff706f2155da4a114b3aec9c0521dba1ebe7cd0af51cd7bba7b2eef60362d12
+MISC metadata.xml 1360 BLAKE2B ed44151f636c3beedf3d33179f4a3955e12e3e243e358ffabe54c40debde0979c305a6eda6299bb84c405a90c383e7c8359c2bfc891cd058311d35e8f63abd52 SHA512 c03d9429276eec061d197f0e2c9c623ad1b83ed3a2d45fc8d655faa64326f753f4a6c4fd783feb988e508272071bbb6780b617f122813a1a9b824339dfeeea47
diff --git a/dev-python/python-gnutls/metadata.xml b/dev-python/python-gnutls/metadata.xml
new file mode 100644
index 000000000000..586a4a287087
--- /dev/null
+++ b/dev-python/python-gnutls/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides a high level object oriented wrapper around
+ libgnutls, as well as low level bindings to the GNUTLS types and
+ functions via ctypes. The high level wrapper hides the details of
+ accessing the GNUTLS library via ctypes behind a set of classes that
+ encapsulate GNUTLS sessions, certificates and credentials and expose
+ them to python applications using a simple API.
+
+ The package also includes a Twisted interface that has seamless
+ intergration with Twisted, providing connectTLS and listenTLS methods
+ on the Twisted reactor once imported (the methods are automatically
+ attached to the reactor by simply importing the GNUTLS Twisted
+ interface module).
+
+ The high level wrapper is written using the GNUTLS library bindings
+ that are made available via ctypes. This makes the wrapper very
+ powerful and flexible as it has direct access to all the GNUTLS
+ internals and is also very easy to extend without any need to write
+ C code or recompile anything.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-gnutls</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild b/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild
new file mode 100644
index 000000000000..b4c46448fa00
--- /dev/null
+++ b/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="High level object oriented wrapper around libgnutls"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/gnutls"