summaryrefslogtreecommitdiff
path: root/dev-python/python-gnutls
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-gnutls
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-gnutls')
-rw-r--r--dev-python/python-gnutls/Manifest4
-rw-r--r--dev-python/python-gnutls/metadata.xml31
-rw-r--r--dev-python/python-gnutls/python-gnutls-3.1.1.ebuild20
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/python-gnutls/Manifest b/dev-python/python-gnutls/Manifest
new file mode 100644
index 000000000000..3b4d52585e23
--- /dev/null
+++ b/dev-python/python-gnutls/Manifest
@@ -0,0 +1,4 @@
+DIST python-gnutls-3.1.1.tar.gz 40593 SHA256 8892681519a89adb5bb1fba62199bb83bb86c999c983d46edf306f13c5f99a59 SHA512 471127d548cc4f44fb7b2da4d6db23cff66378b45eefde2ea4950ee08d849b1a5aed86245cd2a8a5f46fd53c652d433d23b658184a00e8e5514da3f518a080ab WHIRLPOOL 1c28e872dea42adc5a97b6a2d71ccc527047f72a0151326d209533b79a6fd144aea0b3a94eb71b124fb4233a4b093ff38dbb8bddaa1382ab0a6965fdda5b4544
+EBUILD python-gnutls-3.1.1.ebuild 425 SHA256 84e02f02700a04e28b6780161b93ceea836c5e65ad5b7d7073d4edc5ef18587c SHA512 1de48e66fd71b80eadee204031aadb58985b421ed45d8403226b2a35d37255959ff706f2155da4a114b3aec9c0521dba1ebe7cd0af51cd7bba7b2eef60362d12 WHIRLPOOL ecaeedccd2f1e03af8d397e0362a9f629d1e7858bdfdeabd09eab104d54061351695f9cf88fcd91cfa0ff43460ab10289f36866e7686d9a7386586ee0d07b01a
+MISC ChangeLog 947 SHA256 fac1307e274acffcab2b3cac8ec0e8b96d92b38e4edff1615e50137e0b2fdf77 SHA512 9a3f11d2420e7692c5fb1c8ec6a4cce01800bb8283d6860b834df28f09a6e8d8576cc46b9cd2141e6c43581798213c29a0bd638c0096086b4728da6f21ca70fe WHIRLPOOL b5d390eab8ebeeefe2f467f01e8f62e04233ebc28af414d99d4c46e5dfa5b85b3747782bf461de447d67c41bc2191232c44e285890e91fdeb561654bdf2e04be
+MISC metadata.xml 1360 SHA256 f36a9f4e9b266a3e0d116e7c210f90ec3c8ebf2e15529d2a50afdf4adb88866d SHA512 c03d9429276eec061d197f0e2c9c623ad1b83ed3a2d45fc8d655faa64326f753f4a6c4fd783feb988e508272071bbb6780b617f122813a1a9b824339dfeeea47 WHIRLPOOL 5491942393c35c183cb9feacfd00e8b76dd4b176d3c47e003c1c7e7d21be65c187643c43969f94109d190aa9e9d3a0765f16c97c3c38a74542a120d043120353
diff --git a/dev-python/python-gnutls/metadata.xml b/dev-python/python-gnutls/metadata.xml
new file mode 100644
index 000000000000..586a4a287087
--- /dev/null
+++ b/dev-python/python-gnutls/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package provides a high level object oriented wrapper around
+ libgnutls, as well as low level bindings to the GNUTLS types and
+ functions via ctypes. The high level wrapper hides the details of
+ accessing the GNUTLS library via ctypes behind a set of classes that
+ encapsulate GNUTLS sessions, certificates and credentials and expose
+ them to python applications using a simple API.
+
+ The package also includes a Twisted interface that has seamless
+ intergration with Twisted, providing connectTLS and listenTLS methods
+ on the Twisted reactor once imported (the methods are automatically
+ attached to the reactor by simply importing the GNUTLS Twisted
+ interface module).
+
+ The high level wrapper is written using the GNUTLS library bindings
+ that are made available via ctypes. This makes the wrapper very
+ powerful and flexible as it has direct access to all the GNUTLS
+ internals and is also very easy to extend without any need to write
+ C code or recompile anything.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">python-gnutls</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild b/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild
new file mode 100644
index 000000000000..b4c46448fa00
--- /dev/null
+++ b/dev-python/python-gnutls/python-gnutls-3.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="High level object oriented wrapper around libgnutls"
+HOMEPAGE="http://ag-projects.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/gnutls"