summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-04 12:30:23 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-04 12:30:23 +0000
commitdc45b83b28fb83e9659492066e347b8dc60bc9e3 (patch)
treef09e7ed499dae58267ca976cb1880321611f921a /dev-python/python-gnupg
parenteaab68ba6a05bc57d98ca12032440835ef905326 (diff)
gentoo resync 04.02.2018
Diffstat (limited to 'dev-python/python-gnupg')
-rw-r--r--dev-python/python-gnupg/Manifest2
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.4.1.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/Manifest b/dev-python/python-gnupg/Manifest
index e126434273e3..4e1d555dec50 100644
--- a/dev-python/python-gnupg/Manifest
+++ b/dev-python/python-gnupg/Manifest
@@ -1,3 +1,5 @@
DIST python-gnupg-0.4.0.tar.gz 43987 BLAKE2B 59e72f894c5d554ba2a7c348ad3625500798ad6ac18332a3bb668b42559f52b58e3cd0f8b79ef1a99f37e796b48169d0bf36414e938e9039784cede4303cbb03 SHA512 f486ec97aee01cf46d055421211ff5704093a382155043b7ced6f809dc15d7669d5869038a1b26c5f1831076d85c929d781bc22e35ab293a14bc6e2f5f27fa32
+DIST python-gnupg-0.4.1.tar.gz 44534 BLAKE2B 0b58312b9f094b29f7009bb7a44ea3607be826ae2fda958dae0ba9dd5a2d7f81843fe23a6fe336b9df85c059e5b114787dab372df42b14b83cb73fb02abee919 SHA512 0920a1de4d98a745f7747280672975db04c40b59ea4436745cdbefa86a0c88bfdc086d6dd312c82a0a9e9f8cafb5651f8e17d86e0ee37282b5fc36e7ac8d1a1e
EBUILD python-gnupg-0.4.0.ebuild 667 BLAKE2B d8591b491c0738f79f1ce357f1ce9daf6e8d95eea689949ce12f613504980d2a8b97ad821de7a78091ce0a3d5c2598ff118ab76ec8c6c56c9db3e5e6137cb36b SHA512 b0682ddb95ae0d737eae11080dc4cc87562a36367ca40290731be2c6b0c965d9ac427a88d4d2845eaf84e1bca9d34f6ac3d0c8eb8393353340bb2b8164da8c7b
+EBUILD python-gnupg-0.4.1.ebuild 649 BLAKE2B 915c24f18b6b4f56a5fecbe210bb81d241558d0c797e1ede4d0b3dc26acccc6f6b9dff27c977aaea473edf57befec3b37cceec35590bf100478cc31d7912009f SHA512 68965f9f2f3e5ef123843d021ac1aa1928858de66a79e9fe04f3789a049b3a7079bec0f2bde55211cf8f0ae18388d7c818d3e571761401cdc004e1a9922ed3a3
MISC metadata.xml 445 BLAKE2B 56ffcf8992cab03ab335e7fe21d284b46a0335b0a978b5bc7ed3dc38f6df0ffbf8149740aba592011a766eaa0970241bcbc777e74007acdc04063775266223e9 SHA512 4f934dd056cef7f43b98985a52a42ba152c891890f360eb2942167f2ee69ef7fb03476bfde87be8e4e8c178fb7db429d23c695f81dc5d4c3fc266d3a84e827f8
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.1.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.1.ebuild
new file mode 100644
index 000000000000..505d46b3c06d
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+# Tests are still hanging.
+RESTRICT="test"
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}