summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/python-gnupg/python-gnupg-0.4.5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/python-gnupg/python-gnupg-0.4.5.ebuild')
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.4.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild
new file mode 100644
index 000000000000..7d18793f2bc1
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( pypy3 python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python wrapper for GnuPG"
+HOMEPAGE="
+ https://bitbucket.org/vinay.sajip/python-gnupg
+ https://pypi.org/project/python-gnupg/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ # NO_EXTERNAL_TESTS must be enabled,
+ # to disable all tests, which need internet access.
+ NO_EXTERNAL_TESTS=1 "${PYTHON}" test_gnupg.py || die "Tests failed with ${EPYTHON}"
+}